| 网站首页 | 业界新闻 | 小组 | 威客 | 人才 | 下载频道 | 博客 | 代码贴 | 在线编程 | 编程论坛
欢迎加入我们,一同切磋技术
用户名:   
 
密 码:  
共有 941 人关注过本帖
标题:大家知道这个题目的50MS的算法么
只看楼主 加入收藏
企鹅
Rank: 1
等 级:新手上路
帖 子:93
专家分:0
注 册:2006-7-14
收藏
 问题点数:0 回复次数:4 
大家知道这个题目的50MS的算法么

Description
The most important part of a GSM network is so called Base Transceiver Station (BTS). These transceivers form the areas called cells (this term gave the name to the cellular phone) and every phone connects to the BTS with the strongest signal (in a little simplified view). Of course, BTSes need some attention and technicians need to check their function periodically.

ACM technicians faced a very interesting problem recently. Given a set of BTSes to visit, they needed to find the shortest path to visit all of the given points and return back to the central company building. Programmers have spent several months studying this problem but with no results. They were unable to find the solution fast enough. After a long time, one of the programmers found this problem in a conference article. Unfortunately, he found that the problem is so called "Travelling Salesman Problem" and it is very hard to solve. If we have N BTSes to be visited, we can visit them in any order, giving us N! possibilities to examine. The function expressing that number is called factorial and can be computed as a product 1.2.3.4....N. The number is very high even for a relatively small N.

The programmers understood they had no chance to solve the problem. But because they have already received the research grant from the government, they needed to continue with their studies and produce at least some results. So they started to study behaviour of the factorial function.

For example, they defined the function Z. For any positive integer N, Z(N) is the number of zeros at the end of the decimal form of number N!. They noticed that this function never decreases. If we have two numbers N1 < N2, then Z(N1) <= Z(N2). It is because we can never "lose" any trailing zero by multiplying by any positive number. We can only get new and new zeros. The function Z is very interesting, so we need a computer program that can determine its value efficiently.

Input
There is a single positive integer T on the first line of input. It stands for the number of numbers to follow. Then there is T lines, each containing exactly one positive integer number N, 1 <= N <= 1000000000.

Output
For every number N, output a single line containing the single non-negative integer Z(N).

Sample Input


6
3
60
100
1024
23456
8735373

Sample Output


0
14
24
253
5861
2183837
我的想法很简单 只要找出有多少个5因子就OK了 但是时间是600MS 看到有人50MS就搞定了啊
#include <iostream>
using namespace std;

int main()
{
int i,j,total;
cin>>i;
while(i--)
{
total=0;
cin>>j;
while(j!=0)
{
j/=5;
total+=j;
}
cout<<total<<endl;
}
return 0;
}

搜索更多相关主题的帖子: 算法 phone GSM form 
2007-08-10 01:13
HJin
Rank: 6Rank: 6
等 级:贵宾
威 望:27
帖 子:401
专家分:0
注 册:2007-6-9
收藏
得分:0 
good algorithm. You may want to use scanf and printf to shorten the time.


I am working on a system which has no Chinese input. Please don\'t blame me for typing English.
2007-08-12 12:07
aipb2007
Rank: 8Rank: 8
来 自:CQU
等 级:贵宾
威 望:40
帖 子:2879
专家分:7
注 册:2007-3-18
收藏
得分:0 
以下是引用HJin在2007-8-12 12:07:08的发言:
good algorithm. You may want to use scanf and printf to shorten the time.

scanf 和 printf为什么要比c++的标准读写快?


Fight  to win  or  die...
2007-08-13 13:44
HJin
Rank: 6Rank: 6
等 级:贵宾
威 望:27
帖 子:401
专家分:0
注 册:2007-6-9
收藏
得分:0 
回复:(aipb2007)以下是引用HJin在2007-8-12 12:07:...

I don't know why, but all online judge's FAQ's mentioned the fact.


I am working on a system which has no Chinese input. Please don\'t blame me for typing English.
2007-08-14 07:40
aipb2007
Rank: 8Rank: 8
来 自:CQU
等 级:贵宾
威 望:40
帖 子:2879
专家分:7
注 册:2007-3-18
收藏
得分:0 
回复:(HJin)回复:(aipb2007)以下是引用HJin在20...
thx,我也看到的,一般online judge排名靠前的都是用c写的。呵呵~

Fight  to win  or  die...
2007-08-14 10:42
快速回复:大家知道这个题目的50MS的算法么
数据加载中...
 
   



关于我们 | 广告合作 | 编程中国 | 清除Cookies | TOP | 手机版

编程中国 版权所有,并保留所有权利。
Powered by Discuz, Processed in 0.042459 second(s), 8 queries.
Copyright©2004-2024, BCCN.NET, All Rights Reserved