HDOJ1008 电梯问题总 WA 求大神~!
Problem DescriptionThe highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.
For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.
Input
There are multiple test cases. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100. A test case with N = 0 denotes the end of input. This test case is not to be processed.
Output
Print the total time on a single line for each test case.
Sample Input
1 2
3 2 3 1
0
Sample Output
17
41
大体意思就是说电梯刚开始在0层,上升一层用6秒,下降一层用4秒,停在每一层用5秒,让求时间。
#include <stdio.h>
int max(int n);
int min(int n);
int a[100];
int main()
{
int i,sum,up,down,n;
int s;
while (scanf("%d",&n)!=EOF&&n)
{
sum=0;
up=0;
down=0;
if(n==1)//如果只变化一层
{scanf("%d",&s);
sum=sum+s*6+5;}
else {for(i=0;i<n;i++)//如果变化不止一层
scanf("%d",&a[i]);
up=max(n)*6;
down=(max(n)-min(n))*4;
sum=sum+up+down+n*5;}
printf("%d\n",sum);
}
return 0;
}
int max (int n)
{
int i;
for(i=1;i<n;i++)
if(a[i]>a[0])
a[0]=a[i];
return a[0];
}
int min (int n)
{
int i;
for(i=1;i<n;i++)
if(a[i]<a[0])
a[0]=a[i];
return a[0];
}
自己在codeblocks上运行没啥问题,输入了好几组例子都对,但就是一提交他就说WA。
求大神!十分感谢!