| 网站首页 | 业界新闻 | 小组 | 威客 | 人才 | 下载频道 | 博客 | 代码贴 | 在线编程 | 编程论坛
欢迎加入我们,一同切磋技术
用户名:   
 
密 码:  
共有 371 人关注过本帖
标题:为什么不输出结果 ....。。
只看楼主 加入收藏
巴克
Rank: 3Rank: 3
等 级:论坛游侠
帖 子:93
专家分:199
注 册:2012-2-8
结帖率:100%
收藏
已结贴  问题点数:20 回复次数:1 
为什么不输出结果 ....。。
原题在:
http://acm.zju.
Fire Net

--------------------------------------------------------------------------------

Time Limit: 2 Seconds      Memory Limit: 65536 KB

--------------------------------------------------------------------------------

Suppose that we have a square city with straight streets. A map of a city is a square board with n rows and n columns, each representing a street or a piece of wall.

A blockhouse is a small castle that has four openings through which to shoot. The four openings are facing North, East, South, and West, respectively. There will be one machine gun shooting through each opening.

Here we assume that a bullet is so powerful that it can run across any distance and destroy a blockhouse on its way. On the other hand, a wall is so strongly built that can stop the bullets.

The goal is to place as many blockhouses in a city as possible so that no two can destroy each other. A configuration of blockhouses is legal provided that no two blockhouses are on the same horizontal row or vertical column in a map unless there is at least one wall separating them. In this problem we will consider small square cities (at most 4x4) that contain walls through which bullets cannot run through.

The following image shows five pictures of the same board. The first picture is the empty board, the second and third pictures show legal configurations, and the fourth and fifth pictures show illegal configurations. For this board, the maximum number of blockhouses in a legal configuration is 5; the second picture shows one way to do it, but there are several other ways.



Your task is to write a program that, given a description of a map, calculates the maximum number of blockhouses that can be placed in the city in a legal configuration.

The input file contains one or more map descriptions, followed by a line containing the number 0 that signals the end of the file. Each map description begins with a line containing a positive integer n that is the size of the city; n will be at most 4. The next n lines each describe one row of the map, with a '.' indicating an open space and an uppercase 'X' indicating a wall. There are no spaces in the input file.

For each test case, output one line containing the maximum number of blockhouses that can be placed in the city in a legal configuration.

Sample input:

4
.X..
....
XX..
....
2
XX
.X
3
.X.
X.X
.X.
3
...
.XX
.XX
4
....
....
....
....
0

Sample output:

5
1
5
2
4


这是我的代码:
程序代码:
#include<stdio.h>
#include<string.h>
#define false 0
#define true 1

char maps[5][5];
int n,ans;
int judge(int x,int y)
{
    int temp;

    if(maps[x][y] == 'X')return 0;
    for(temp=1;temp<y;temp++)
        if(maps[x][temp] == 'X')break;
        else if(maps[x][temp] == 'C')return 0;
    for(temp=y+1;temp<=n;temp++)
        if(maps[x][temp] == 'X')break;
        else if(maps[x][temp] == 'C')return 0;
    for(temp=1;temp<x;temp++)
        if(maps[temp][y] == 'X')break;
        else if(maps[temp][y] == 'C')return 0;
    for(temp=x+1;temp<=n;temp++)
        if(maps[temp][y] == 'X')break;
        else if(maps[temp][y] == 'C')return 0;

    return 1;
}

void dfs(int k)
{
    int i,j;
    for(i=1;i<=n;i++)
    {
        for(j=1;j<=n;j++)
        {
            if(judge(i,j))
            {
                maps[i][j] = 'C';
                dfs(k+1);
                maps[i][j] = '.';
            }
        }
    }

    ans = ans>k?ans:k;
}
int main()
{
    int i,j;

    while(1)
    {
        scanf("%d",&n);
        if(n == 0)break;
        scanf("\n");
        for(i=1;i<=n;i++)
        {
            for(j=1;j<=n;j++)
                scanf("%c",&maps[i][j]);
            if(i<n)
            scanf("\n");
        }

        ans = 0;
        dfs(0);
        printf("%d\n",ans);
    }
    return 0;
}


为什么不出现结果啊啊。。。
搜索更多相关主题的帖子: Memory 
2012-07-17 12:13
彼岸光影
Rank: 2
等 级:论坛游民
帖 子:20
专家分:25
注 册:2012-6-4
收藏
得分:20 
我觉得 你的函数好乱的啊,好多实参都没法给形参传值……
2012-07-17 15:18
快速回复:为什么不输出结果 ....。。
数据加载中...
 
   



关于我们 | 广告合作 | 编程中国 | 清除Cookies | TOP | 手机版

编程中国 版权所有,并保留所有权利。
Powered by Discuz, Processed in 0.021034 second(s), 8 queries.
Copyright©2004-2024, BCCN.NET, All Rights Reserved