| 网站首页 | 业界新闻 | 小组 | 威客 | 人才 | 下载频道 | 博客 | 代码贴 | 在线编程 | 编程论坛
欢迎加入我们,一同切磋技术
用户名:   
 
密 码:  
共有 596 人关注过本帖
标题:hdu杭电2052为什么老是WRONG ANSWER, 还有数组用完之后第二次还用,怎么初始 ...
只看楼主 加入收藏
bianchenyang
Rank: 2
等 级:论坛游民
帖 子:21
专家分:26
注 册:2011-11-14
结帖率:33.33%
收藏
 问题点数:0 回复次数:2 
hdu杭电2052为什么老是WRONG ANSWER, 还有数组用完之后第二次还用,怎么初始化?
#include<stdio.h>
int main()
{
    int m,n,i,j;
    char a[75][75]={""};
    while(scanf("%d%d",&m,&n)!=EOF)
    {
        for(i=0;i<n+2;i++)
        {
            for(j=0;j<m+2;j++)
            {
                a[i][0]=a[i][m+1]='+';
            }
        }
        for(i=1;i<=m;i++)
        {
            a[0][i]='-';
        }
        for(i=1;i<=m;i++)
        {
            a[n+1][i]='-';
        }
        for(i=1;i<n+1;i++)
        {
                a[i][0]=a[i][m+1]='|';
        }
        for(i=0;i<n+2;i++)
        {
            for(j=0;j<m+2;j++)
            {
                printf("%c",a[i][j]);
            }
            printf("\n");
        }
        for(i=0;i<75;i++)
        {
            for(j=0;j<75;j++)
            {
                a[i][j]=' ';
            }
        }
        printf("\n");
    }
    return 0;
}
题目:
Problem Description
Give you the width and height of the rectangle,darw it.
 

Input
Input contains a number of test cases.For each case ,there are two numbers n and m (0 < n,m < 75)indicate the width and height of the rectangle.Iuput ends of EOF.
 

Output
For each case,you should draw a rectangle with the width and height giving in the input.
after each case, you should a blank line.
 

Sample Input
3 2
 

Sample Output
+---+
|   |
|   |
+---+



[ 本帖最后由 bianchenyang 于 2011-11-15 09:26 编辑 ]
搜索更多相关主题的帖子: include 
2011-11-15 09:20
laoyang103
Rank: 19Rank: 19Rank: 19Rank: 19Rank: 19Rank: 19
来 自:内蒙古包头
等 级:贵宾
威 望:19
帖 子:3082
专家分:11056
注 册:2010-5-22
收藏
得分:0 
这个题格式很搞人  注意最后一句after each case, you should a blank line
程序代码:
#include <stdio.h>

int main()
{
    int i,j,k;
    int w,h;
    while(EOF != scanf("%d%d",&w,&h))
    {
        char a[77][77] = {0};
        a[0][0] = '+';a[0][w+1] = '+';
        a[h+1][0] = '+';a[h+1][w+1] = '+';
        for(i = 1;i<=w;i++)
            a[0][i] = a[h+1][i] = '-';
        for(i = 1;i<=h;i++)
            a[i][0] = a[i][w+1] = '|';
        for(i = 0;i<=h+1;i++)
        {
            for(j = 0;j<=w+1;j++)
                if(a[i][j])
                    putchar(a[i][j]);
                else
                    putchar(' ');
            printf("\n");
        }
        printf("\n");
    }   
    return 0;
}


                                         
===========深入<----------------->浅出============
2011-11-15 10:18
bianchenyang
Rank: 2
等 级:论坛游民
帖 子:21
专家分:26
注 册:2011-11-14
收藏
得分:0 
回复 2楼 laoyang103
谢谢你,我又学了一些东西  
2011-11-15 16:50
快速回复:hdu杭电2052为什么老是WRONG ANSWER, 还有数组用完之后第二次还用,怎 ...
数据加载中...
 
   



关于我们 | 广告合作 | 编程中国 | 清除Cookies | TOP | 手机版

编程中国 版权所有,并保留所有权利。
Powered by Discuz, Processed in 0.016907 second(s), 8 queries.
Copyright©2004-2024, BCCN.NET, All Rights Reserved