| 网站首页 | 业界新闻 | 小组 | 威客 | 人才 | 下载频道 | 博客 | 代码贴 | 在线编程 | 编程论坛
欢迎加入我们,一同切磋技术
用户名:   
 
密 码:  
共有 402 人关注过本帖
标题:求教POJ_1575_Easier Done Than Said?
只看楼主 加入收藏
HSU
Rank: 1
等 级:新手上路
帖 子:19
专家分:0
注 册:2010-1-3
结帖率:83.33%
收藏
 问题点数:0 回复次数:0 
求教POJ_1575_Easier Done Than Said?
题目如下:

描述
Password security is a tricky thing. Users prefer simple passwords that are easy to remember (like buddy), but such passwords are often insecure. Some sites use random computer-generated passwords (like xvtpzyo), but users have a hard time remembering them and sometimes leave them written on notes stuck to their computer. One potential solution is to generate "pronounceable" passwords that are relatively secure but still easy to remember.

FnordCom is developing such a password generator. You work in the quality control department, and it's your job to test the generator and make sure that the passwords are acceptable. To be acceptable, a password must satisfy these three rules:

It must contain at least one vowel.

It cannot contain three consecutive vowels or three consecutive consonants.

It cannot contain two consecutive occurrences of the same letter, except for 'ee' or 'oo'.

(For the purposes of this problem, the vowels are 'a', 'e', 'i', 'o', and 'u'; all other letters are consonants.) Note that these rules are not perfect; there are many common/pronounceable words that are not acceptable.


输入
The input consists of one or more potential passwords, one per line, followed by a line containing only the word 'end' that signals the end of the file. Each password is at least one and at most twenty letters long and consists only of lowercase letters.
输出
For each password, output whether or not it is acceptable, using the precise format shown in the example.
样例输入
a
tv
ptoui
bontres
zoggax
wiinq
eep
houctuh
end

样例输出
<a> is acceptable.
<tv> is not acceptable.
<ptoui> is not acceptable.
<bontres> is not acceptable.
<zoggax> is not acceptable.
<wiinq> is not acceptable.
<eep> is acceptable.
<houctuh> is acceptable.


我的代码:
# include <stdio.h>
# include <string.h>

int main()
{
    char str[50];/*用于存放输入的字符串*/
    int i,vowels;
    int condition1, condition2, condition3;
    int vo_counter, co_counter;
    char model[5]= {"end"};
    while ( 1 )
    {
        
        /* defaule value */
        vowels = 0;
        condition1 = 0, condition2 = 0, condition3 = 0;
        vo_counter = 0, co_counter = 0;   
        
        scanf("%s",str);
        if ( strcmp(str,model) == 0 )
            break;
        for ( i=0 ; str[i]!='\0' ; i++)
        {
            /* condition 1 */
            if ( str[i] =='a' || str[i] =='e' || str[i] =='i' || str[i] =='o' || str[i] =='u')
            {
                vowels++;
            }
            if ( vowels >=1 )
                condition1 = 1;
            
            /* condition 2 */
            if ( str[i] == 'a' || str[i] == 'e' || str[i] == 'i' || str[i] == 'o'
                || str[i] == 'u')
                if ( str[i+1] == 'a' || str[i+1] == 'e' || str[i+1] == 'i'
                    || str[i+1] == 'o' || str[i+1] == 'u')
                    if ( str[i+2] == 'a' || str[i+2] == 'e' || str[i+2] == 'i'
                        || str[i+2] == 'o' || str[i+2] == 'u')
                        condition2 = 1;
                    if ( str[i] > 'a' && str[i] <= 'd' || str[i] > 'e' && str[i] <= 'h'
                        || str[i] > 'h' && str[i] <='n' || str[i] > 'o' && str[i] <= 't'
                        || str[i] > 'u'&& str[i] <= 'z' )
                        if ( str[i+1] > 'a' && str[i+1] <='d' || str[i+1] > 'e' && str[i+1] <= 'h'
                            || str[i+1] > 'h' && str[i+1] <='n' || str[i+1] > 'o'
                                && str   [i+1] <= 't' || str[i+1] > 'u' && str[i+1] <= 'z')
                            if ( str[i+2] > 'a' && str[i+2] <= 'd' || str[i+2] > 'e' && str[i+2] <= 'h'
                                || str[i+2] > 'h' && str[i+2] <='n' || str[i+2] > 'o'
                               && str[i+2] <= 't' || str[i+2] > 'u' && str[i+2] <= 'z')
                                condition2 = 1;
                           
                            /* condition 3 */
                            if ( str[i] == str[i+1] )
                            {
                                condition3 = 1;
                                if ( str[i] == 'e' || str[i] == 'o')
                                    condition3 = 0;
                            }
        }
        
        /* output */
        if ( condition1 == 1 && condition2 == 0 && condition3 == 0)
            printf("&lt;%s&gt; is acceptable.\n", str);
        else
            printf("&lt;%s&gt; is not acceptable.\n", str);   
    }
    return 0;
}

我的问题:
此程序测试给出的事例没有问题,但提交总是WA。
求教为何?
搜索更多相关主题的帖子: Done Said Easier POJ Than 
2010-08-31 12:18
快速回复:求教POJ_1575_Easier Done Than Said?
数据加载中...
 
   



关于我们 | 广告合作 | 编程中国 | 清除Cookies | TOP | 手机版

编程中国 版权所有,并保留所有权利。
Powered by Discuz, Processed in 0.016107 second(s), 8 queries.
Copyright©2004-2024, BCCN.NET, All Rights Reserved