| 网站首页 | 业界新闻 | 小组 | 威客 | 人才 | 下载频道 | 博客 | 代码贴 | 在线编程 | 编程论坛
欢迎加入我们,一同切磋技术
用户名:   
 
密 码:  
共有 2537 人关注过本帖
标题:Runtime Error通常是什么原因的?程序在这!
只看楼主 加入收藏
zwqbq
Rank: 1
等 级:新手上路
帖 子:21
专家分:0
注 册:2008-9-13
收藏
 问题点数:0 回复次数:3 
Runtime Error通常是什么原因的?程序在这!
这是题目:
Maya Calendar
Time Limit: 1000MS  Memory Limit: 10000K
Total Submissions: 23485  Accepted: 7095

Description

During his last sabbatical, professor M. A. Ya made a surprising discovery about the old Maya calendar. From an old knotted message, professor discovered that the Maya civilization used a 365 day long year, called Haab, which had 19 months. Each of the first 18 months was 20 days long, and the names of the months were pop, no, zip, zotz, tzec, xul, yoxkin, mol, chen, yax, zac, ceh, mac, kankin, muan, pax, koyab, cumhu. Instead of having names, the days of the months were denoted by numbers starting from 0 to 19. The last month of Haab was called uayet and had 5 days denoted by numbers 0, 1, 2, 3, 4. The Maya believed that this month was unlucky, the court of justice was not in session, the trade stopped, people did not even sweep the floor.

For religious purposes, the Maya used another calendar in which the year was called Tzolkin (holly year). The year was divided into thirteen periods, each 20 days long. Each day was denoted by a pair consisting of a number and the name of the day. They used 20 names: imix, ik, akbal, kan, chicchan, cimi, manik, lamat, muluk, ok, chuen, eb, ben, ix, mem, cib, caban, eznab, canac, ahau and 13 numbers; both in cycles.

Notice that each day has an unambiguous description. For example, at the beginning of the year the days were described as follows:

1 imix, 2 ik, 3 akbal, 4 kan, 5 chicchan, 6 cimi, 7 manik, 8 lamat, 9 muluk, 10 ok, 11 chuen, 12 eb, 13 ben, 1 ix, 2 mem, 3 cib, 4 caban, 5 eznab, 6 canac, 7 ahau, and again in the next period 8 imix, 9 ik, 10 akbal . . .

Years (both Haab and Tzolkin) were denoted by numbers 0, 1, : : : , where the number 0 was the beginning of the world. Thus, the first day was:

Haab: 0. pop 0

Tzolkin: 1 imix 0
Help professor M. A. Ya and write a program for him to convert the dates from the Haab calendar to the Tzolkin calendar.

Input

The date in Haab is given in the following format:
NumberOfTheDay. Month Year

The first line of the input file contains the number of the input dates in the file. The next n lines contain n dates in the Haab calendar format, each in separate line. The year is smaller then 5000.

Output

The date in Tzolkin should be in the following format:
Number NameOfTheDay Year

The first line of the output file contains the number of the output dates. In the next n lines, there are dates in the Tzolkin calendar format, in the order corresponding to the input dates.

Sample Input

3
10. zac 0
0. pop 0
10. zac 1995
Sample Output

3
3 chuen 0
1 imix 0
9 cimi 2801

这是原代码:
#include<stdio.h>
#include<string.h>
#define SIZE 100
char HaabMonth[19][10]={"pop","no","zip","zotz","tzec","xul","yoxkin","mol","chen","yax","zac",
                        "ceh","mac","kankin","muan","pax","koyab","cumhu","uayet"};
char HollyName[20][10]={"imix","ik","akbal","kan","chicchan","cimi","manik","lamat","muluk","ok",
                        "chuen","eb","ben","ix","mem","cib","caban","eznab","canac","ahau"};
struct output
{
    int No;
    char *Name;
    int Year;
};

int main()
{
    int n,day,year,m,t,f;
    char s[10];
    struct output P[SIZE];
    scanf("%d",&n);
    for(f=0;f<n;f++)
    {
        scanf("%d. %s %d",&day,s,&year);
        for(m=0;m<19;m++)
            if(strcmp(HaabMonth[m],s)==0)
                break;
        t=day+20*m+365*year;  
        P[f].No=1+t%13;
        P[f].Name=HollyName[t%20];
        P[f].Year=t/260;
    }
    printf("%d\n",n);
    for(f=0;f<n;f++)
        printf("%d %s %d\n",P[f].No,P[f].Name,P[f].Year);
    return 0;
}

[[it] 本帖最后由 zwqbq 于 2008-9-13 00:57 编辑 [/it]]
搜索更多相关主题的帖子: Runtime 
2008-09-13 00:30
hcanhong
Rank: 1
来 自:肇庆学院网络工程系
等 级:新手上路
帖 子:58
专家分:0
注 册:2008-9-6
收藏
得分:0 
2008-09-13 00:50
zwqbq
Rank: 1
等 级:新手上路
帖 子:21
专家分:0
注 册:2008-9-13
收藏
得分:0 
我已解决,多谢看了我程序的朋友们!
2008-09-14 16:54
zwqbq
Rank: 1
等 级:新手上路
帖 子:21
专家分:0
注 册:2008-9-13
收藏
得分:0 
一个很简单的程序,能运行却没结果,请高手帮帮忙!
//设A=(a1,a2...,an)和B=(b1,b2...,bn)均为顺序表,比较A与B大小
#include <stdio.h>
#include <stdlib.h>
#define LIST_INIT_SIZE 100
#define LISTINCREMENT 10
#define OVERFLOW 0
#define LEN sizeof(Sqlist)
typedef struct {
    char * elem;
    int length;
    int listsize;
}Sqlist;
void InitList_Sq(Sqlist &L) {
    /*构造一个空的线性表*/
    L.elem=(char *)malloc(LIST_INIT_SIZE * sizeof(char));
    if (!L.elem) exit(OVERFLOW);
    L.length = 0;
    L.listsize = LIST_INIT_SIZE;
    return;
} /*InitList_Sq*/



void Comparison_Sq(Sqlist A, Sqlist B) {
    int i = 0;
    while( i < A.length  && i < B.length )
    {
    if( A.elem[i] < B.elem[i] )
       {
        printf("A < B\n");
      
       }
    else if( A.elem[i] > B.elem[i] )
    printf("A > B\n");
    
    else
       i ++;
    }
    if(A.length < B.length )
    {
        printf("A < B\n");
     
    }
    else if ( A.length > B.length )
    {
        printf("A > B");
        
    }
    else
    {
        printf("A == B");
      
    }
}

void main()
{
    Sqlist A,B;

    int i=0,j=0;
    char flag;

    InitList_Sq(A); //构造空表A
    InitList_Sq(B); //构造空表B
    printf("请输入A的字母序列:\n");
    while(scanf("%c",&flag),A.listsize>=i) {
        if (flag == '\n') break;
        else {
                A.elem[i]=flag;  
                flag = NULL;
                A.length++;
                i++;
             }
        }
    printf("请输入B的字母序列:\n");
    while(scanf("%c",&flag),B.listsize>=j) {
        if (flag == '\n') break;
        else {
            B.elem[j]=flag;
            flag = NULL;
            B.length++;
            j++;} }
    /*比较:*/
    Comparison_Sq(A,B);
  
}
2008-09-14 16:56
快速回复:Runtime Error通常是什么原因的?程序在这!
数据加载中...
 
   



关于我们 | 广告合作 | 编程中国 | 清除Cookies | TOP | 手机版

编程中国 版权所有,并保留所有权利。
Powered by Discuz, Processed in 0.029803 second(s), 8 queries.
Copyright©2004-2024, BCCN.NET, All Rights Reserved