| 网站首页 | 业界新闻 | 小组 | 威客 | 人才 | 下载频道 | 博客 | 代码贴 | 在线编程 | 编程论坛
欢迎加入我们,一同切磋技术
用户名:   
 
密 码:  
共有 551 人关注过本帖
标题:怎样改进这个程序?
只看楼主 加入收藏
xujie3
Rank: 1
来 自:浙江
等 级:新手上路
帖 子:51
专家分:0
注 册:2008-7-22
收藏
 问题点数:0 回复次数:2 
怎样改进这个程序?
这道题目有时间限制,所以下面的我编的程序还不合格,请大家帮帮忙,看看如何改进,还有编程风格上的问题也可以指出来,先谢谢了。

Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.

 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).

 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.

 

Sample Input
2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5
 

Sample Output
Case 1:
14 1 4

Case 2:
7 1 6
 
#include <stdio.h>

int main()
{
    float N;
    int T,i,j,s,sum,max,max_start,max_end;
    short a[100000];
    scanf("%d",&T);
    for (i=0;i<T;i++){
       scanf("%f",&N);
       for (j=0;j<N;j++)
          scanf("%d",&a[j]);

       max=a[0];
       for ( s=0; s<N; s++ ){
           sum=0;
           for ( j=s; j<N; j++ ){
               sum+=a[j];
               if (sum>max){
                 max=sum;
                 max_start=s+1;
                 max_end=j+1;
               }
           }
       }
       printf("Case %d:\n",i+1);
       printf("%d %d %d\n",max,max_start,max_end);
    }


}
搜索更多相关主题的帖子: 改进 
2008-08-20 22:48
xujie3
Rank: 1
来 自:浙江
等 级:新手上路
帖 子:51
专家分:0
注 册:2008-7-22
收藏
得分:0 
程序做了改进,运行时间长的问题已经解决了,下面是代码



#include <stdio.h>
#include <limits.h>  /*头文件<limits.h>表示了一些整型大小的常量,                  
                       下面程序中用到的INT_MIN=-32767*/
int main()
{
    int t,T;



    scanf("%d",&T);
    for  (t=0;t<T;t++){   /*T表示test的个数*/
        int n,a,i;
        int max=INT_MIN;
        int max_start,max_end;
        int start,end,sum;
        scanf("%d",&n);    /*n是每个test中数的个数*/

        start=0;
        sum=0;

        for (end=0;end<n;end++){
           scanf("%d",&a);
           sum+=a;
           if (sum>max){
             max=sum;
             max_start=start;
             max_end=end;
           }
           if (sum<0){        /*求每个test行中值最大的子串,如果从start到目前的end
             start=end+1;      加起来的数sum<0,则前面这段数字可去,start重新从end+1开始
             sum=0;            */
           }

        }
       printf("Case %d:\n",t+1);
       printf("%d %d %d\n",max,max_start+1,max_end+1);
       if(t!=T-1)
         printf("\n");

    }

}
2008-08-21 13:06
xujie3
Rank: 1
来 自:浙江
等 级:新手上路
帖 子:51
专家分:0
注 册:2008-7-22
收藏
得分:0 
发帖子时候以为没发出去所以又发了一次,现在就有两张帖了,帖子发了之后回帖的人比较少,不过上面的现在可以算是一道比较完整的题目加参考了,有兴趣的可以看看。第二个程序在c++环境下运行。
2008-08-21 13:13
快速回复:怎样改进这个程序?
数据加载中...
 
   



关于我们 | 广告合作 | 编程中国 | 清除Cookies | TOP | 手机版

编程中国 版权所有,并保留所有权利。
Powered by Discuz, Processed in 0.019976 second(s), 8 queries.
Copyright©2004-2024, BCCN.NET, All Rights Reserved