| 网站首页 | 业界新闻 | 小组 | 威客 | 人才 | 下载频道 | 博客 | 代码贴 | 在线编程 | 编程论坛
欢迎加入我们,一同切磋技术
用户名:   
 
密 码:  
共有 2005 人关注过本帖
标题:求平均值
只看楼主 加入收藏
xujie3
Rank: 1
来 自:浙江
等 级:新手上路
帖 子:51
专家分:0
注 册:2008-7-22
收藏
 问题点数:0 回复次数:3 
求平均值
Larry graduated this year and finally has a job. He's making a lot of money, but somehow never seems to have enough. Larry has decided that he needs to grab hold of his financial portfolio and solve his financing problems. The first step is to figure out what's been going on with his money. Larry has his bank account statements and wants to see how much money he has. Help Larry by writing a program to take his closing balance from each of the past twelve months and calculate his average account balance.


Input Format:

The input will be twelve lines. Each line will contain the closing balance of his bank account for a particular month. Each number will be positive and displayed to the penny. No dollar sign will be included.


Output Format:

The output will be a single number, the average (mean) of the closing balances for the twelve months. It will be rounded to the nearest penny, preceded immediately by a dollar sign, and followed by the end-of-line. There will be no other spaces or characters in the output.




Sample Input:

100.00
489.12
12454.12
1234.10
823.05
109.20
5.27
1542.25
839.18
83.99
1295.01
1.75


Sample Output:

$1581.42







上面是题目,这样写哪里有错,求教?

#include <stdio.h>

int main()
{
    int i;
    double a[12],s=0;
    for(i=0;i<12;i++)
       {
        scanf("%f",&a[i]);
        s+=a[i];
        }
     printf("$%.2f",s/12);
     
     return 0;
 }
搜索更多相关主题的帖子: 平均值 
2008-07-27 13:38
coming
Rank: 1
等 级:新手上路
帖 子:244
专家分:0
注 册:2008-4-20
收藏
得分:0 
#include <stdio.h>

int main()
{
    int i;
    double a[12],s=0;
    for(i=0;i<12;i++)
       {
        scanf("%lf",&a[i]);//类型要匹配 用%lf
        s+=a[i];
        }
     printf("$%.2lf",s/12);//同理
     
     return 0;
}
//这样应该就好了吧
2008-07-27 13:53
tyyy
Rank: 1
等 级:新手上路
帖 子:23
专家分:0
注 册:2008-7-25
收藏
得分:0 
s应该定义为浮点型
2008-07-27 16:59
xujie3
Rank: 1
来 自:浙江
等 级:新手上路
帖 子:51
专家分:0
注 册:2008-7-22
收藏
得分:0 
谢谢楼上两位了。
2008-07-27 21:02
快速回复:求平均值
数据加载中...
 
   



关于我们 | 广告合作 | 编程中国 | 清除Cookies | TOP | 手机版

编程中国 版权所有,并保留所有权利。
Powered by Discuz, Processed in 0.018703 second(s), 8 queries.
Copyright©2004-2024, BCCN.NET, All Rights Reserved