| 网站首页 | 业界新闻 | 小组 | 威客 | 人才 | 下载频道 | 博客 | 代码贴 | 在线编程 | 编程论坛
欢迎加入我们,一同切磋技术
用户名:   
 
密 码:  
共有 1110 人关注过本帖
标题:此程序如何编写 是利用数组嘛, 请各位指路
只看楼主 加入收藏
A16310320524
Rank: 1
等 级:新手上路
帖 子:5
专家分:5
注 册:2016-11-1
结帖率:100%
收藏
已结贴  问题点数:10 回复次数:4 
此程序如何编写 是利用数组嘛, 请各位指路
Description
Your task is to Calculate the sum of some integers.
Input
Input contains multiple test cases. Each test case contains a integer N, and then N integers follow in the same line. A test case starting with 0 terminates the input and this test case is not to be processed.
Output
For each group of input integers you should output their sum in one line, and with one line of output for each line in input.
Sample Input
4 1 2 3 4
5 1 2 3 4 5
0
Sample Output
10
15
搜索更多相关主题的帖子: multiple starting follow should 
2016-11-01 16:36
linlulu001
Rank: 13Rank: 13Rank: 13Rank: 13
等 级:贵宾
威 望:20
帖 子:944
专家分:4047
注 册:2016-4-13
收藏
得分:10 
/*你参考下,对不对就不知道了,毕竟英文学的不咋地*/
#include <stdio.h>
#define M 10        //数组不够大,改这里就好了。
int main()
{
    int sum[M],n,k=0;
    for(int i=0;i<M;++i)
        sum[i]=0;
    while(scanf("%d",&n)&&n!=0&&k<M)
    {
        for(int i=0;i<n;++i)
        {
            int l;
            scanf("%d",&l);
            sum[k]+=l;
        }
        ++k;
    }
    for(int i=0;i<k;++i)
        printf("%d\n",sum[i]);
    return 0;
}
2016-11-01 21:42
A16310320524
Rank: 1
等 级:新手上路
帖 子:5
专家分:5
注 册:2016-11-1
收藏
得分:0 
回复 2楼 linlulu001
程序是错误的
2016-11-01 23:29
炎天
Rank: 13Rank: 13Rank: 13Rank: 13
来 自:桃花岛
等 级:贵宾
威 望:29
帖 子:1218
专家分:4986
注 册:2016-9-15
收藏
得分:0 
以下是引用A16310320524在2016-11-1 23:29:37的发言:

程序是错误的


错在哪了?

早知做人那么辛苦!  当初不应该下凡
2016-11-02 00:00
A16310320524
Rank: 1
等 级:新手上路
帖 子:5
专家分:5
注 册:2016-11-1
收藏
得分:0 
#include<stdio.h>
int main()
{
    int n,i,sum;
    int a[100];
    while(~scanf("%d",&n))
    {
        sum=0;
        if(n==0)
        return 0;
        else
        {
            for(i=0;i<n;i++)
    {
    scanf("%d",&a[i]);
    sum+=a[i];
     }
     printf("%d\n",sum);
    }
        }
    return 0;
 }
/*应该可以吧 你试试*/

[此贴子已经被作者于2017-2-12 18:17编辑过]

2017-02-12 18:16
快速回复:此程序如何编写 是利用数组嘛, 请各位指路
数据加载中...
 
   



关于我们 | 广告合作 | 编程中国 | 清除Cookies | TOP | 手机版

编程中国 版权所有,并保留所有权利。
Powered by Discuz, Processed in 0.018686 second(s), 10 queries.
Copyright©2004-2024, BCCN.NET, All Rights Reserved