| 网站首页 | 业界新闻 | 小组 | 威客 | 人才 | 下载频道 | 博客 | 代码贴 | 在线编程 | 编程论坛
欢迎加入我们,一同切磋技术
用户名:   
 
密 码:  
共有 5616 人关注过本帖
标题:杭电 acm 1003 max sum 问题,求解析
只看楼主 加入收藏
狂盗一枝梅
Rank: 1
等 级:新手上路
帖 子:8
专家分:0
注 册:2012-12-23
结帖率:0
收藏
已结贴  问题点数:10 回复次数:6 
杭电 acm 1003 max sum 问题,求解析
这个题我没有思路,就上网上找了一个代码,ac了,但是事实上我还不明白为什么这么做,我主要有两点疑惑:1.为什么代码里要设sum和max的初始值为-1000。2.为什么代码里的
             if(sum>=0)
             {
                 kj++;
                 sum += m;
             }
             else
             {
                 ki = i;
                 kj = i;
                 sum = m;
             }
    这部分代码要以sum>=0和sum<0为判断条件。
Max Sum
Time Limit: 2000MS Memory limit: 32768K
题目描述
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
输入
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
输出
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
示例输入
2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5示例输出
Case 1:
14 1 4

Case 2:
7 1 6

程序代码:
#include<stdio.h>

 int main()

 {
     int t,n,i,max,m,sum,ki,kj,k,a,b;
     scanf("%d",&t);
     for(k=1;k<=t;k++)
     {
         scanf("%d",&n);
         max = -1000;
         sum = -1000;
         a = b = 1;
         ki = kj = 1;
        // printf("max=%d sum=%d\n",max,sum);
         for(i=1;i<=n;i++)
         {
             scanf("%d",&m);
             if(sum>=0)
             {
                 kj++;
                 sum += m;
             }
             else
             {
                 ki = i;
                 kj = i;
                 sum = m;
             }
             //printf("ki=%d kj=%d a=%d b=%d sum=%d max=%d\n",ki,kj,a,b,sum);
             if(max<sum)
             {
                 max = sum;
                 a = ki;
                 b = kj;
             }
            // printf("ki=%d kj=%d a=%d b=%d sum=%d max=%d\n\n",ki,kj,a,b,sum,max);
         }
         if(k==1) printf("Case %d:\n%d %d %d\n",k,max,a,b);
         else printf("\nCase %d:\n%d %d %d\n",k,max,a,b);
     }
     return 0;

 }
搜索更多相关主题的帖子: max Memory 
2013-05-24 21:02
Susake
Rank: 15Rank: 15Rank: 15Rank: 15Rank: 15
来 自:女儿国的隔壁
等 级:贵宾
威 望:23
帖 子:2288
专家分:6481
注 册:2012-12-14
收藏
得分:3 
1.then N integers followed(all the integers are between -1000 and 1000).
2.最大子段和的算法

仰望星空...........不忘初心!
2013-05-24 21:11
Ryker
Rank: 6Rank: 6
等 级:侠之大者
威 望:1
帖 子:145
专家分:420
注 册:2013-2-19
收藏
得分:3 
我题我提交了N遍..一直WA

我百度别人的答案,明明判断条件都一样的..就是不给通过


设为-1001 是因为(all the integers are between -1000 and 1000)
2013-05-24 21:14
Susake
Rank: 15Rank: 15Rank: 15Rank: 15Rank: 15
来 自:女儿国的隔壁
等 级:贵宾
威 望:23
帖 子:2288
专家分:6481
注 册:2012-12-14
收藏
得分:0 
Output a blank line between two cases.

仰望星空...........不忘初心!
2013-05-24 21:23
我叫沃恩
Rank: 12Rank: 12Rank: 12
来 自:Asia
等 级:贵宾
威 望:10
帖 子:1234
专家分:3865
注 册:2013-3-29
收藏
得分:3 
all the integers are between -1000 and 1000这是你第一点的疑惑!
同意2楼!做这些题要小心!!

因为我是菜鸟,所以应该被骂! 细节+坚持=成功!
2013-05-25 07:38
邓士林
Rank: 19Rank: 19Rank: 19Rank: 19Rank: 19Rank: 19
来 自:淮河河畔
等 级:贵宾
威 望:61
帖 子:2392
专家分:13384
注 册:2013-3-3
收藏
得分:3 
题目条件要注意下,看英文的真费劲

Maybe
2013-05-25 16:43
快速回复:杭电 acm 1003 max sum 问题,求解析
数据加载中...
 
   



关于我们 | 广告合作 | 编程中国 | 清除Cookies | TOP | 手机版

编程中国 版权所有,并保留所有权利。
Powered by Discuz, Processed in 0.016397 second(s), 9 queries.
Copyright©2004-2024, BCCN.NET, All Rights Reserved