求解一个类似于斐波拉契数列的问题
Problem DescriptionA number sequence is defined as follows:
f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.
Given A, B, and n, you are to calculate the value of f(n).
Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.
Output
For each test case, print the value of f(n) on a single line.
Sample Input
1 1 3
1 2 10
0 0 0
Sample Output
2
5
我的程序是这样的,但提交到OJ却显示Memory Limit Exceeded,超过内存限制,求各位大神教教小弟怎么修改?还有这种类似问题应该怎么做才能避免超内存呢?
#include<stdio.h>
int k[100000001];
int main()
{
int a,b,n,i;
while(scanf("%d %d %d",&a,&b,&n)==3,a!=0||b!=0||n!=0)
{
k[0]=1;
k[1]=1;
for(i=2;i<100000001;i++)
{
k[i]=(a*k[i-1]+b*k[i-2])%7;
}
printf("%d\n",k[n-1]);
}
return 0;
}