求最大子串和,杭电acm题,为什么不能通过。。。
InputThe first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
Sample Input
2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5
Sample Output
Case 1: 14 1 4
Case 2: 7 1 6
程序如下:
#include<stdio.h>
struct
{
int max;
int start;
int end;
}myexp[20];
int main()
{
int i;
int j;
int a;
int T;
int N;
scanf("%d",&T);
for(i = 0;i < T;i++)
{
int sum = 0;
myexp[i].max = -1001;
int tmp = 1;
scanf("%d",&N);
for(j = 0;j < N;j++)
{
scanf("%d",&a);
sum = sum + a;
if(sum > myexp[i].max)
{
myexp[i].max = sum;
myexp[i].start = tmp;
myexp[i].end = j + 1;
}
if(sum < 0)
{
sum = 0;
tmp = j + 2;
}
}
}
for(i = 0;i < T;i++)
{
printf("case %d:\n",i + 1);
printf("%d %d %d\n",myexp[i].max,myexp[i].start,myexp[i].end);
printf("\n");
}
return 0;
}