| 网站首页 | 业界新闻 | 小组 | 威客 | 人才 | 下载频道 | 博客 | 代码贴 | 在线编程 | 编程论坛
欢迎加入我们,一同切磋技术
用户名:   
 
密 码:  
共有 1145 人关注过本帖
标题:杭电1003,AC有兴趣来看看
只看楼主 加入收藏
Buger
Rank: 1
等 级:新手上路
帖 子:60
专家分:7
注 册:2013-3-20
结帖率:84.62%
收藏
已结贴  问题点数:1 回复次数:13 
杭电1003,AC有兴趣来看看
Max Sum
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 98153    Accepted Submission(s): 22614
Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
Sample Input
2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5
Sample Output
Case 1:
14 1 4
Case 2:
7 1 6
以下是我的代码,不知道是不是我哪里看漏了,麻烦大家帮忙指正下...谢谢
程序代码:
#include <stdio.h>
#define N 100000 + 10
int main() {
    int T, n, a[N], sum, t, i, k, j;
    scanf("%d", &T);
    for(t = 1; t <= T; t++) {
        scanf("%d", &n);
        sum = 0;
        for(i = 1; i <= n; i++) {
            scanf("%d", &a[i]);
        }
        for(i = 1; i <= n; i++)
            if(a[i] >= 0) {
                j = i;
                break;
            }
        for(i = n; i >= 1; i--)
            if(a[i] >= 0) {
                k = i;
                break;
            }
        for(i = j; i <= k; i++) sum += a[i];
        printf("Case %d:\n%d %d %d\n", t, sum, j, k);
        if(t < T) printf("\n");
    }
    return 0;
}
新号没什么分,望大家包涵....
搜索更多相关主题的帖子: max sequence example Memory 
2013-03-21 02:07
Buger
Rank: 1
等 级:新手上路
帖 子:60
专家分:7
注 册:2013-3-20
收藏
得分:0 
希望能指出我的错误所在,不求新的代码...
http://acm.hdu.
2013-03-21 02:09
邓士林
Rank: 19Rank: 19Rank: 19Rank: 19Rank: 19Rank: 19
来 自:淮河河畔
等 级:贵宾
威 望:61
帖 子:2392
专家分:13384
注 册:2013-3-3
收藏
得分:0 
我没看你的程序,给你测试了下,用上面的测试数据可以啊!程序编译又没有错误

Maybe
2013-03-21 08:21
beyondyf
Rank: 19Rank: 19Rank: 19Rank: 19Rank: 19Rank: 19
等 级:贵宾
威 望:103
帖 子:3282
专家分:12654
注 册:2008-1-21
收藏
得分:1 
你的错误所在在于算法压根就不对。这个问题叫最大子段和,是动态规划的教学级案例,不是简单地卡个头尾就能解决的。举个例子 1 -100 10 你觉得结果该是什么。

重剑无锋,大巧不工
2013-03-21 08:35
fourleaves
Rank: 2
等 级:论坛游民
帖 子:194
专家分:99
注 册:2010-5-8
收藏
得分:0 
,算法效率可以优化到o(n).给你个提示先预处理算出所有sj.代表重从a0加到aj的。用sj-si可以算出ai+1到aj的和,懂了没~~~别说还不懂~~

再复杂的问题也基于最简单的原理。耐心,耐心!丰富自己!等待时机!
2013-03-21 11:29
Buger
Rank: 1
等 级:新手上路
帖 子:60
专家分:7
注 册:2013-3-20
收藏
得分:0 
哦哦...多谢,学习了...
2013-03-21 11:37
Buger
Rank: 1
等 级:新手上路
帖 子:60
专家分:7
注 册:2013-3-20
收藏
得分:0 
吸收大家的意见去试了下,但是还是不行
程序代码:
#include <stdio.h>
#define N 100000 + 10
int main() {
     int T, n, a[N], sum, t, i, k, j, b;
     scanf("%d", &T);
     for(t = 1; t <= T; t++) {
         scanf("%d", &n);
         sum = 0; b = 0;
         for(i = 1; i <= n; i++) {
             scanf("%d", &a[i]);
             if(b > 0) b += a[i];
             else b = a[i];
             if(b > sum) {
                 sum = b;
                 k = i;
             }
         }
         for(i = 1; i <= n; i++) {
             if(a[i] >= 0) j = i;
             break;
         }
         printf("Case %d:\n%d %d %d\n", t, sum, j, k);
         if(t < T) printf("\n");
     }
     return 0;

 }

2013-03-23 23:45
Buger
Rank: 1
等 级:新手上路
帖 子:60
专家分:7
注 册:2013-3-20
收藏
得分:0 
说说我的思路吧方便大家查错
1.用for输入n个数
2.最长字段算法算出max
并找出最后的i
3,重新for找到第一个>=0的数
这就是我的思路
2013-03-24 00:08
czz5242199
Rank: 11Rank: 11Rank: 11Rank: 11
等 级:小飞侠
威 望:4
帖 子:660
专家分:2400
注 册:2011-10-26
收藏
得分:0 
第三布明显错了
2013-03-24 00:25
Buger
Rank: 1
等 级:新手上路
帖 子:60
专家分:7
注 册:2013-3-20
收藏
得分:0 
那该怎么弄,给思路就好。。。。
2013-03-24 00:44
快速回复:杭电1003,AC有兴趣来看看
数据加载中...
 
   



关于我们 | 广告合作 | 编程中国 | 清除Cookies | TOP | 手机版

编程中国 版权所有,并保留所有权利。
Powered by Discuz, Processed in 0.022598 second(s), 7 queries.
Copyright©2004-2024, BCCN.NET, All Rights Reserved