| 网站首页 | 业界新闻 | 小组 | 威客 | 人才 | 下载频道 | 博客 | 代码贴 | 在线编程 | 编程论坛
欢迎加入我们,一同切磋技术
用户名:   
 
密 码:  
共有 984 人关注过本帖, 1 人收藏
标题:求最大子串和,杭电acm题,为什么不能通过。。。
取消只看楼主 加入收藏
Melody_FHM
Rank: 1
等 级:新手上路
帖 子:1
专家分:0
注 册:2011-8-26
结帖率:0
收藏(1)
已结贴  问题点数:20 回复次数:0 
求最大子串和,杭电acm题,为什么不能通过。。。
Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
Sample Input
2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5

Sample Output
Case 1: 14 1 4
Case 2: 7 1 6

程序如下:
#include<stdio.h>
struct
{
    int max;
        int start;
        int end;
}myexp[20];
   
int main()
{
          int i;
          int j;
          int a;
          int T;
          int N;
          scanf("%d",&T);
          for(i = 0;i < T;i++)
          {
                 int sum = 0;
                 myexp[i].max = -1001;
                 int tmp = 1;
                 scanf("%d",&N);
                 for(j = 0;j < N;j++)
                 {
                          scanf("%d",&a);
                          sum = sum + a;
                          if(sum > myexp[i].max)
                          {
                                  myexp[i].max = sum;
                                  myexp[i].start = tmp;
                                  myexp[i].end = j + 1;
                          }
                          if(sum < 0)
                          {
                                  sum = 0;
                                  tmp = j + 2;
                          }
                  }
          }
                                                                                                                              
          for(i = 0;i < T;i++)
          {
                  printf("case %d:\n",i + 1);
                  printf("%d %d %d\n",myexp[i].max,myexp[i].start,myexp[i].end);
                 printf("\n");
         }
         return 0;
 }
搜索更多相关主题的帖子: position sequence between number follow 
2011-08-26 04:17
快速回复:求最大子串和,杭电acm题,为什么不能通过。。。
数据加载中...
 
   



关于我们 | 广告合作 | 编程中国 | 清除Cookies | TOP | 手机版

编程中国 版权所有,并保留所有权利。
Powered by Discuz, Processed in 0.018237 second(s), 8 queries.
Copyright©2004-2024, BCCN.NET, All Rights Reserved