| 网站首页 | 业界新闻 | 小组 | 威客 | 人才 | 下载频道 | 博客 | 代码贴 | 在线编程 | 编程论坛
欢迎加入我们,一同切磋技术
用户名:   
 
密 码:  
共有 1405 人关注过本帖
标题:hdu问题,Digital Roots
取消只看楼主 加入收藏
ZJQLOVELYY
Rank: 3Rank: 3
等 级:论坛游侠
帖 子:105
专家分:166
注 册:2011-8-1
结帖率:100%
收藏
已结贴  问题点数:5 回复次数:2 
hdu问题,Digital Roots
The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is repeated. This is continued as long as necessary to obtain a single digit.

For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.
 

Input
The input file will contain a list of positive integers, one per line. The end of the input will be indicated by an integer value of zero.
 

Output
For each integer in the input, output its digital root on a separate line of the output.
 

Sample Input
24
39
0
 

Sample Output
6
3
程序代码:
#include<stdio.h>
int main()
{
    int n,sum=0;
    while(scanf("%d",&n)!=EOF&&n!=0)
    {
        sum=0;
        while(n!=0)
        {
            sum+=n%10;
            n/=10;
            if(sum>10&&n==0)
            {    
                n=sum;
                sum=0;
            }
        }
        printf("%d\n",sum);
    }
    return 0;
}
我这个程序为什么通过不了的,,显示Wrong answer
搜索更多相关主题的帖子: single necessary continued positive 
2011-11-22 12:23
ZJQLOVELYY
Rank: 3Rank: 3
等 级:论坛游侠
帖 子:105
专家分:166
注 册:2011-8-1
收藏
得分:0 
回复 2楼 jcw08120110
这个程序应该不行,,在输入38的时候,即sum大于9的时候,还是会输出sum,再去计算,,,这样就不符合题意了
2011-11-23 14:04
ZJQLOVELYY
Rank: 3Rank: 3
等 级:论坛游侠
帖 子:105
专家分:166
注 册:2011-8-1
收藏
得分:0 
回复 4楼 jcw08120110
这个也过不了!
2011-11-23 14:17
快速回复:hdu问题,Digital Roots
数据加载中...
 
   



关于我们 | 广告合作 | 编程中国 | 清除Cookies | TOP | 手机版

编程中国 版权所有,并保留所有权利。
Powered by Discuz, Processed in 0.012309 second(s), 8 queries.
Copyright©2004-2024, BCCN.NET, All Rights Reserved