| 网站首页 | 业界新闻 | 小组 | 交易 | 人才 | 下载频道 | 博客 | 代码贴 | 在线编程 | 编程论坛
共有 1802 人关注过本帖
标题:win7 64位系统与vb6.0兼容性问题
只看楼主 加入收藏
浔度1
Rank: 1
等 级:新手上路
帖 子:36
专家分:0
注 册:2015-10-9
结帖率:20%
  已结贴   问题点数:20  回复次数:8   
win7 64位系统与vb6.0兼容性问题
在xp系统上用vb6.0企业版编了一个程序,能正常运行。但是换win7 64位系统后,再用源代码运行程序的时候,程序就不能正常运行了,提示“未找到提供程序。该程序可能未正确安装”,请问是什么原因。
搜索更多相关主题的帖子: 运行程序  源代码  xp系统  兼容性  企业版  
2017-05-09 22:27
Artless
Rank: 19Rank: 19Rank: 19Rank: 19Rank: 19Rank: 19
等 级:贵宾
威 望:103
帖 子:4211
专家分:28888
注 册:2009-4-8
  得分:7 
vb6.0企业版在win7安装完成吗

无知
2017-05-10 00:08
浔度1
Rank: 1
等 级:新手上路
帖 子:36
专家分:0
注 册:2015-10-9
  得分:0 
回复 2楼 Artless
安装好了,其他编的程序都能正常运行。连接的是access数据库,但是版本升级为10版了,以前是07版,不知道是不是这个原因...
2017-05-10 19:27
ZHRXJR
Rank: 20Rank: 20Rank: 20Rank: 20Rank: 20
等 级:版主
威 望:98
帖 子:878
专家分:4612
注 册:2016-5-10
  得分:7 
估计是版本问题,最有可能是Office的版本,如果以前是2003的,现在是2007以上的,打开Access数据库就会出现“未找到提供程序。该程序可能未正确安装”的错误。
XP系统大多数是2003版本的Office,不知道你的是什么。
2017-05-11 19:28
浔度1
Rank: 1
等 级:新手上路
帖 子:36
专家分:0
注 册:2015-10-9
  得分:0 
回复 4楼 ZHRXJR
我前面xp系统装的是office2007,程序运行时没有问题的。用的是ado连接(accdb),按理说换office2010以后连接引擎是不会变的(数据库格式没改变)。今天试着把数据库文件保存为mdb格式的,把连接引擎改为jet连接,又能连上了。就不清楚到底是哪里出了问题了?难道是win7缺少文件,不支持ace连接?但是又是缺少什么文件呢?
2017-05-11 20:35
风吹过b
Rank: 20Rank: 20Rank: 20Rank: 20Rank: 20
等 级:版主
威 望:251
帖 子:4406
专家分:27045
注 册:2008-10-15
  得分:7 
office2010 的连接字串与低版本的不同,使用 ADOBC 连接时,连接字串,好像是 内部指定的。
使用JET连接时,这个通用的。

授人于鱼,不如授人于渔
早已停用QQ了
2017-05-11 20:47
浔度1
Rank: 1
等 级:新手上路
帖 子:36
专家分:0
注 册:2015-10-9
  得分:0 
回复 6楼 风吹过b
能说得详细点吗?
2017-05-11 21:13
风吹过b
Rank: 20Rank: 20Rank: 20Rank: 20Rank: 20
等 级:版主
威 望:251
帖 子:4406
专家分:27045
注 册:2008-10-15
  得分:0 
没环境,没测试过,也没遇到过。

大概是:关键看你 选择的 驱动
前面论坛就 就说过驱动问题。
Access 驱动有二种,一种是 jet ,
一种是 Microsoft Access Driver ,这种驱动与 office的版本有关。
好象 2007版是一个槛,前后互不兼容。不记得了。

授人于鱼,不如授人于渔
早已停用QQ了
2017-05-11 23:11
浔度1
Rank: 1
等 级:新手上路
帖 子:36
专家分:0
注 册:2015-10-9
  得分:0 
回复 8楼 风吹过b
感谢了。只有在摸索一下了
2017-05-25 21:32







关于我们 | 广告合作 | 编程中国 | 清除Cookies | TOP | 手机版

编程中国 版权所有,并保留所有权利。
Powered by Discuz, Processed in 0.029646 second(s), 8 queries.
Copyright©2004-2019, BCCN.NET, All Rights Reserved