| 网站首页 | 业界新闻 | 小组 | 威客 | 人才 | 下载频道 | 博客 | 代码贴 | 在线编程 | 编程论坛
欢迎加入我们,一同切磋技术
用户名:   
 
密 码:  
共有 581 人关注过本帖
标题:程序中有一个怪怪的 求指正
只看楼主 加入收藏
凉粉呵呵
Rank: 1
等 级:新手上路
帖 子:73
专家分:0
注 册:2013-2-10
结帖率:81.82%
收藏
已结贴  问题点数:5 回复次数:2 
程序中有一个怪怪的 求指正
Triangular Sums
时间限制:3000 ms  |  内存限制:65535 KB
难度:2
描述
The nth Triangular number, T(n) = 1 + … + n, is the sum of the first n integers. It is the number of points in a triangular array with n points on side. For example T(4):

X
X X
X X X
X X X X
Write a program to compute the weighted sum of triangular numbers:

W(n) = SUM[k = 1…n; k * T(k + 1)]

输入
The first line of input contains a single integer N, (1 ≤ N ≤ 1000) which is the number of datasets that follow.

Each dataset consists of a single line of input containing a single integer n, (1 ≤ n ≤300), which is the number of points on a side of the triangle.
输出
For each dataset, output on a single line the dataset number (1 through N), a blank, the value of n for the dataset, a blank, and the weighted sum ,W(n), of triangular numbers for n.
样例输入
4
3
4
5
10
样例输出
1 3 45
2 4 105
3 5 210
4 10 2145



源代码:

#include<stdio.h>
int T(int b)
{
    int u=0;
    b=b+1;
    while(b--)
    {
//        printf("%d\n",b);
        u=u+b;
        
    }
//        printf("%d\n",u);
    return u;
}



int fact(int a)
{
    int i,sum=0;
    for(i=1;i<=a;i++)
        sum=i*T(i+1)+sum;

    return sum;
}



int main()
{
    int n,a,sum,i;
    scanf("%d",&n);
    for(i=1;i<=n;i++)
    {
        scanf("%d",&a);
        sum=fact(a);
        printf("%d %d %d\n",i,a,sum);
    }
    return 0;
}



/*样例输入
4
3
4
5
10
样例输出
1 3 45
2 4 105
3 5 210
4 10 2145*/



问题:在调用函数T()中想不明白为什么b还要加1,如果没加过不了oj,自己已经在fact传递的是i+1了~
搜索更多相关主题的帖子: first single example numbers follow 
2013-03-31 08:51
不要脸的猫
Rank: 3Rank: 3
等 级:论坛游侠
威 望:2
帖 子:41
专家分:126
注 册:2012-6-20
收藏
得分:4 
//假设temp=b;
b=b+1;//temp=b+1;
while(b--)//temp=b;
{……}//楼主懂了吗?

埋骨何须桑梓地,人生无处不青山
2013-03-31 09:33
凉粉呵呵
Rank: 1
等 级:新手上路
帖 子:73
专家分:0
注 册:2013-2-10
收藏
得分:0 
回复 2楼 不要脸的猫
你好,b--是先赋值再自减~--b就是你所说的情况~  两个不一样~
2013-03-31 22:49
快速回复:程序中有一个怪怪的 求指正
数据加载中...
 
   



关于我们 | 广告合作 | 编程中国 | 清除Cookies | TOP | 手机版

编程中国 版权所有,并保留所有权利。
Powered by Discuz, Processed in 0.013075 second(s), 7 queries.
Copyright©2004-2024, BCCN.NET, All Rights Reserved