| 网站首页 | 业界新闻 | 小组 | 威客 | 人才 | 下载频道 | 博客 | 代码贴 | 在线编程 | 编程论坛
欢迎加入我们,一同切磋技术
用户名:   
 
密 码:  
共有 633 人关注过本帖
标题:求助个闰年的题目
只看楼主 加入收藏
xuyao18
Rank: 2
等 级:论坛游民
帖 子:50
专家分:30
注 册:2009-4-27
结帖率:22.22%
收藏
 问题点数:0 回复次数:0 
求助个闰年的题目
Problem Description
Ignatius was born in a leap year, so he want to know when he could hold his birthday party. Can you tell him?

Given a positive integers Y which indicate the start year, and a positive integer N, your task is to tell the Nth leap year from year Y.

Note: if year Y is a leap year, then the 1st leap year is year Y.

 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains two positive integers Y and N(1<=N<=10000).

 

Output
For each test case, you should output the Nth leap year from year Y.

 

Sample Input
3
2005 25
1855 12
2004 10000
 

Sample Output
2108
1904
43236







题目在上面,我想问问 为什么是2004 年以后的第10000个是43236啊?


我写的程序是
#include <stdio.h>
void main ()
{
    int N,n,Y,i;
    scanf("%d",&N);
    for(i=0;i<N;i++)
    {
        scanf("%d%d",&Y,&n);
        flag:;
        if((Y%4==0&&Y%100!=0)||Y%400==0)printf("%d\n",Y+4*n);
        else
        {
            Y++;
            goto flag;
        }
    }
}


OJ上一直提示WRONG ANSWER。。。 求各位达人提示提示。  实在想不出哪错了
搜索更多相关主题的帖子: 闰年 
2009-12-27 18:19
快速回复:求助个闰年的题目
数据加载中...
 
   



关于我们 | 广告合作 | 编程中国 | 清除Cookies | TOP | 手机版

编程中国 版权所有,并保留所有权利。
Powered by Discuz, Processed in 0.011618 second(s), 7 queries.
Copyright©2004-2024, BCCN.NET, All Rights Reserved