| 网站首页 | 业界新闻 | 小组 | 威客 | 人才 | 下载频道 | 博客 | 代码贴 | 在线编程 | 编程论坛
欢迎加入我们,一同切磋技术
用户名:   
 
密 码:  
共有 415 人关注过本帖
标题:ACM题目 有谁能解答一下一
只看楼主 加入收藏
a505720273
Rank: 1
等 级:新手上路
帖 子:3
专家分:0
注 册:2009-8-17
结帖率:100%
收藏
已结贴  问题点数:20 回复次数:1 
ACM题目 有谁能解答一下一
Hangover
Time Limit: 1000MS  Memory Limit: 10000K
Total Submissions: 46617  Accepted: 21827

Description

How far can you make a stack of cards overhang a table? If you have one card, you can create a maximum overhang of half a card length. (We're assuming that the cards must be perpendicular to the table.) With two cards you can make the top card overhang the bottom one by half a card length, and the bottom one overhang the table by a third of a card length, for a total maximum overhang of 1/2 + 1/3 = 5/6 card lengths. In general you can make n cards overhang by 1/2 + 1/3 + 1/4 + ... + 1/(n + 1) card lengths, where the top card overhangs the second by 1/2, the second overhangs tha third by 1/3, the third overhangs the fourth by 1/4, etc., and the bottom card overhangs the table by 1/(n + 1). This is illustrated in the figure below.






Input

The input consists of one or more test cases, followed by a line containing the number 0.00 that signals the end of the input. Each test case is a single line containing a positive floating-point number c whose value is at least 0.01 and at most 5.20; c will contain exactly three digits.
Output

For each test case, output the minimum number of cards necessary to achieve an overhang of at least c card lengths. Use the exact output format shown in the examples.
Sample Input

1.00
3.71
0.04
5.19
0.00

Sample Output

3 card(s)
61 card(s)
1 card(s)
273 card(s)
搜索更多相关主题的帖子: TAG 
2009-08-18 10:23
a505720273
Rank: 1
等 级:新手上路
帖 子:3
专家分:0
注 册:2009-8-17
收藏
得分:0 
这道题答案如下有谁能都帮忙解释一下为什么这样做啊?

#include<stdio.h>
int main()
{
   float c;
   int i;
   double sum;
   scanf("%f",&c);
   while((double)c>=0.01)  
      {
       sum=0.0;
       for(i=1;sum<(double)c;i++)
        sum=sum+1.0/(double)(i+1);
        printf("%d card(s)\n",i-1);
        scanf("%f",&c);
      }  
     return 0;  
}  
2009-08-18 10:24
快速回复:ACM题目 有谁能解答一下一
数据加载中...
 
   



关于我们 | 广告合作 | 编程中国 | 清除Cookies | TOP | 手机版

编程中国 版权所有,并保留所有权利。
Powered by Discuz, Processed in 0.015965 second(s), 7 queries.
Copyright©2004-2024, BCCN.NET, All Rights Reserved