| 网站首页 | 业界新闻 | 小组 | 威客 | 人才 | 下载频道 | 博客 | 代码贴 | 在线编程 | 编程论坛
欢迎加入我们,一同切磋技术
用户名:   
 
密 码:  
共有 1480 人关注过本帖
标题:谁能给我点意见 我的超时
只看楼主 加入收藏
心剑菩提
Rank: 1
等 级:新手上路
帖 子:249
专家分:0
注 册:2007-5-17
收藏
 问题点数:0 回复次数:13 
谁能给我点意见 我的超时

Alphacode
Description
Alice and Bob need to send secret messages to each other and are discussing ways to encode their messages:
Alice: “Let’s just use a very simple code: We’ll assign ‘A’ the code word 1, ‘B’ will be 2, and so on down to ‘Z’ being assigned 26.”
Bob: “That’s a stupid code, Alice. Suppose I send you the word ‘BEAN’ encoded as 25114. You could decode that in many different ways!”
Alice: “Sure you could, but what words would you get? Other than ‘BEAN’, you’d get ‘BEAAD’, ‘YAAD’, ‘YAN’, ‘YKD’ and ‘BEKD’. I think you would be able to figure out the correct decoding. And why would you send me the word ‘BEAN’ anyway?”
Bob: “OK, maybe that’s a bad example, but I bet you that if you got a string of length 500 there would be tons of different decodings and with that many you would find at least two different ones that would make sense.”
Alice: “How many different decodings?”
Bob: “Jillions!”
For some reason, Alice is still unconvinced by Bob’s argument, so she requires a program that will determine how many decodings there can be for a given string using her code.


Input

Input will consist of multiple input sets. Each set will consist of a single line of digits representing a
valid encryption (for example, no line will begin with a 0). There will be no spaces between the digits.
An input line of ‘0’ will terminate the input and should not be processed


Output

For each input set, output the number of possible decodings for the input string. All answers will be
within the range of a long variable.


Sample Input


25114
1111111111
3333333333
0


Sample Output


6
89
1


#include <stdio.h>
#include <iostream>
using namespace std;
int total(char *p);
int total(char *p)
{
int num,sum=0;
if (strlen(p) == 1)
return 1;
else if (strlen(p) == 2)
{
num = (*p - '0') * 10 + (*(p+1) - '0');
if (num <= 26)
sum = 2;
else
sum = 1;
}
else
{
num = (*p - '0') * 10 + (*(p+1) - '0');
if (num <= 26)
sum = total (p + 1) + total (p + 2);
else
sum = total (p + 1);
}
return sum;
}
int main()
{
char s[1000];
while (EOF != scanf("%s", s) && *s != '0')
printf("%d\n", total(s));
return 0;
}

[此贴子已经被作者于2007-11-2 16:02:49编辑过]

搜索更多相关主题的帖子: 意见 超时 
2007-10-30 15:29
leeco
Rank: 4
等 级:贵宾
威 望:10
帖 子:1029
专家分:177
注 册:2007-5-10
收藏
得分:0 
超时是显然的
2007-10-30 15:59
心剑菩提
Rank: 1
等 级:新手上路
帖 子:249
专家分:0
注 册:2007-5-17
收藏
得分:0 

指点一下

[此贴子已经被作者于2007-11-2 13:26:01编辑过]


前世五百次的回眸 才换来今生的擦肩而过
2007-10-30 16:04
leeco
Rank: 4
等 级:贵宾
威 望:10
帖 子:1029
专家分:177
注 册:2007-5-10
收藏
得分:0 

自己想啊,我帮你改了你又学不会,对你对我都没好处

2007-10-30 20:29
心剑菩提
Rank: 1
等 级:新手上路
帖 子:249
专家分:0
注 册:2007-5-17
收藏
得分:0 

不会吧


前世五百次的回眸 才换来今生的擦肩而过
2007-10-30 21:23
心剑菩提
Rank: 1
等 级:新手上路
帖 子:249
专家分:0
注 册:2007-5-17
收藏
得分:0 

怎么看

[此贴子已经被作者于2007-11-2 13:25:35编辑过]


前世五百次的回眸 才换来今生的擦肩而过
2007-10-31 10:27
心剑菩提
Rank: 1
等 级:新手上路
帖 子:249
专家分:0
注 册:2007-5-17
收藏
得分:0 

或者你有更好的思路呢??

[此贴子已经被作者于2007-11-2 13:27:53编辑过]


前世五百次的回眸 才换来今生的擦肩而过
2007-10-31 13:52
卧龙孔明
Rank: 9Rank: 9Rank: 9
等 级:贵宾
威 望:59
帖 子:3872
专家分:684
注 册:2006-10-13
收藏
得分:0 
有中文翻译吗?

My Blog: www.aiexp.info
虽然我的路是从这里开始的,但是这里不再是乐土.感谢曾经影响过,引导过,帮助过我的董凯,飞燕,leeco,starwing,Rockcarry,soft_wind等等等等.别了,BCCN.
2007-11-03 21:12
孤魂居士
Rank: 2
来 自:老A(中国地大)
等 级:论坛游民
威 望:4
帖 子:1142
专家分:18
注 册:2007-5-21
收藏
得分:0 

准备用3年做个高级软件工程师 10年也做不成。准备用10年做成高级软件工程师 3年就成了QQ 群 45771086
欢迎版主...欢迎JAVA爱好者...
一起从深夜 到凌晨...
2007-11-03 23:33
cosdos
Rank: 9Rank: 9Rank: 9
来 自:ShangHai
等 级:蜘蛛侠
威 望:6
帖 子:2109
专家分:1385
注 册:2007-6-19
收藏
得分:0 

int total(char *p)
{
int num,
sum=0;

if(strlen(p) == 1)
return 1;
else if(strlen(p) == 2)
{
num = (*p - '0') * 10 + (*(p+1) - '0');
if(num <= 26)
sum = 2;
else
sum = 1;
}
else
{
num = (*p - '0') * 10 + (*(p+1) - '0');
if(num <= 26)
sum = total (p + 1) + total (p + 2);
else
sum = total (p + 1);
}
return sum;
}

这个函数干什么的


—>〉Sun〈<—
2007-11-03 23:57
快速回复:谁能给我点意见 我的超时
数据加载中...
 
   



关于我们 | 广告合作 | 编程中国 | 清除Cookies | TOP | 手机版

编程中国 版权所有,并保留所有权利。
Powered by Discuz, Processed in 0.011945 second(s), 7 queries.
Copyright©2004-2024, BCCN.NET, All Rights Reserved