| 网站首页 | 业界新闻 | 小组 | 威客 | 人才 | 下载频道 | 博客 | 代码贴 | 在线编程 | 编程论坛
欢迎加入我们,一同切磋技术
用户名:   
 
密 码:  
共有 1432 人关注过本帖
标题:帮忙看一下,有没有特殊的例子证明这个代码不对
只看楼主 加入收藏
枫叶无痕
Rank: 2
等 级:论坛游民
帖 子:80
专家分:30
注 册:2011-2-10
结帖率:73.91%
收藏
已结贴  问题点数:20 回复次数:2 
帮忙看一下,有没有特殊的例子证明这个代码不对
Fire Net

Time Limit:1000MS  Memory Limit:65536K
Total Submit:294 Accepted:174

Description

Suppose that we have a square city with straight streets. A map of a city is a square board with n rows and n columns, each representing a street or a piece of wall.

A blockhouse is a small castle that has four openings through which to shoot. The four openings are facing North, East, South, and West, respectively. There will be one machine gun shooting through each opening.

Here we assume that a bullet is so powerful that it can run across any distance and destroy a blockhouse on its way. On the other hand, a wall is so strongly built that can stop the bullets.

The goal is to place as many blockhouses in a city as possible so that no two can destroy each other. A configuration of blockhouses is legal provided that no two blockhouses are on the same horizontal row or vertical column in a map unless there is at least one wall separating them. In this problem we will consider small square cities (at most 4x4) that contain walls through which bullets cannot run through.

The following image shows five pictures of the same board. The first picture is the empty board, the second and third pictures show legal configurations, and the fourth and fifth pictures show illegal configurations. For this board, the maximum number of blockhouses in a legal configuration is 5; the second picture shows one way to do it, but there are several other ways.
 
Your task is to write a program that, given a description of a map, calculates the maximum number of blockhouses that can be placed in the city in a legal configuration.






Input

The input file contains one or more map descriptions, followed by a line containing the number 0 that signals the end of the file. Each map description begins with a line containing a positive integer n that is the size of the city; n will be at most 4. The next n lines each describe one row of the map, with a '.' indicating an open space and an uppercase 'X' indicating a wall. There are no spaces in the input file.


Output

For each test case, output one line containing the maximum number of blockhouses that can be placed in the city in a legal configuration.

Sample Input


4
.X..
....
XX..
....
2
XX
.X
3
.X.
X.X
.X.
3
...
.XX
.XX
4
....
....
....
....
0

Sample Output


5
1
5
2
4

Source

Zhejiang University Local Contest 2001 zj01002



代码;;

#include<stdio.h>
#include<string.h>
char str[10][10];
int map[10][10];
int n;
int bfs()
{
    int i,j,k;
    int count;
    count=1;
    for(i=1;i<=n;i++)
    {
        for(j=1;j<=n;j++)
        {
            if(map[i][j]!=1&&str[i][j]!='X')
            {
                for(k=i;k<=n&&str[k][j]!='X';k++)
                {
                    map[k][j]=1;
                }
                for(k=i;k>=1&&str[k][j]!='X';k--)
                {
                    map[k][j]=1;
                }
                for(k=j;k<=n&&str[i][k]!='X';k++)
                {
                    map[i][k]=1;
                }
                for(k=j;k>=1&&str[i][k]!='X';k--)
                {
                    map[i][k]=1;
                }
                count++;
            }
        }
    }
    return count;
}
int main()
{
    int i,j,k;
    while(scanf("%d",&n)&&n)
    {
        for(i=1;i<=n;i++)
        {
            scanf("%s",str[i]+1);
        }
        int max;
        max=0;
        int count;
        for(i=1;i<=n;i++)
        {
            for(j=1;j<=n;j++)
            {
                if(str[i][j]=='.')
                {
                    memset(map,0,sizeof(map));
                    for(k=i;k<=n&&str[k][j]!='X';k++)
                    {
                        map[k][j]=1;
                    }
                    for(k=i;k>=1&&str[k][j]!='X';k--)
                    {
                        map[k][j]=1;
                    }
                    for(k=j;k<=n&&str[i][k]!='X';k++)
                    {
                        map[i][k]=1;
                    }
                    for(k=j;k>=1&&str[i][k]!='X';k--)
                    {
                        map[i][k]=1;
                    }
                    count=bfs();
                    if(count>max)
                    max=count;
                }
            }
        }
        printf("%d\n",max);
    }
    return 0;
}
搜索更多相关主题的帖子: machine through Memory castle 
2011-08-21 17:40
zh77
Rank: 2
来 自:江苏
等 级:论坛游民
帖 子:84
专家分:22
注 册:2011-8-5
收藏
得分:0 
米有
2011-08-21 17:49
voidx
Rank: 12Rank: 12Rank: 12
来 自:邯郸
等 级:火箭侠
帖 子:1250
专家分:3538
注 册:2011-4-7
收藏
得分:20 
程序代码:
// 如下:
4
....
..X.
.X.X
....

// 正解为 6 ,如下 (+ 为碉堡):
..+.
.+X+
+X+X
.+..


[ 本帖最后由 voidx 于 2011-8-21 19:01 编辑 ]
2011-08-21 18:58
快速回复:帮忙看一下,有没有特殊的例子证明这个代码不对
数据加载中...
 
   



关于我们 | 广告合作 | 编程中国 | 清除Cookies | TOP | 手机版

编程中国 版权所有,并保留所有权利。
Powered by Discuz, Processed in 0.016431 second(s), 8 queries.
Copyright©2004-2024, BCCN.NET, All Rights Reserved