| 网站首页 | 业界新闻 | 小组 | 威客 | 人才 | 下载频道 | 博客 | 代码贴 | 在线编程 | 编程论坛
欢迎加入我们,一同切磋技术
用户名:   
 
密 码:  
共有 963 人关注过本帖
标题:求教:一道关于栈的问题
只看楼主 加入收藏
Alen0128
Rank: 4
等 级:业余侠客
帖 子:171
专家分:222
注 册:2009-12-26
结帖率:76.19%
收藏
已结贴  问题点数:20 回复次数:6 
求教:一道关于栈的问题
这是有关于栈的一道ACM题,我做了一下,有问题,貌似是判断栈空是出错了,请教大侠们(我的代码在最下面)
下面是问题的描述:

Problem Description:

As the new term comes, the Ignatius Train Station is very busy nowadays. A lot of student want to get back to school by train(because the trains in the Ignatius Train Station is the fastest all over the world ^v^). But here comes a problem, there is only one railway where all the trains stop. So all the trains come in from one side and get out from the other side. For this problem, if train A gets into the railway first, and then train B gets into the railway before train A leaves, train A can't leave until train B leaves. The pictures below figure out the problem. Now the problem for you is, there are at most 9 trains in the station, all the trains has an ID(numbered from 1 to n), the trains get into the railway in an order O1, your task is to determine whether the trains can get out in an order O2.
图片附件: 游客没有浏览图片的权限,请 登录注册
图片附件: 游客没有浏览图片的权限,请 登录注册
图片附件: 游客没有浏览图片的权限,请 登录注册


Input
The input contains several test cases. Each test case consists of an integer, the number of trains, and two strings, the order of the trains come in:O1, and the order of the trains leave:O2. The input is terminated by the end of file. More details in the Sample Input.
 
Output
The output contains a string "No." if you can't exchange O2 to O1, or you should output a line contains "Yes.", and then output your way in exchanging the order(you should output "in" for a train getting into the railway, and "out" for a train getting out of the railway). Print a line contains "FINISH" after each test case. More details in the Sample Output.
 
Sample Input
3 123 321
3 123 312

Sample Output
Yes.
in
in
in
out
out
out
FINISH
No.
FINISH



搜索更多相关主题的帖子: only because problem school 
2010-07-19 09:42
Alen0128
Rank: 4
等 级:业余侠客
帖 子:171
专家分:222
注 册:2009-12-26
收藏
得分:0 
程序代码:
#include <stdio.h>
#include <stdlib.h>

typedef struct Node
{
    char order[9];
    int top;
}Train;

void Push(Train* train);
char Pop(Train* train);
int Judge(Train* train, char order[], int icase);
void Print(int icase);
int Empty(Train* train);

int main()
{
    int i = 0;
    int icase = 0;
    Train* train = (Train*)malloc(sizeof(Train));        //order1
    char order[9];                                        //order2

    while (scanf("%d",&icase)!=EOF && icase<10)
    {
        getchar();
        train->top = -1;

        for (i=0; i<icase; i++)
        {
            Push(train);
        }
           
        getchar();
           
        for (i=0; i<icase; i++)
        {
            scanf("%c",&order[i]);
        }
           
        if (Judge(train,order,icase))
        {
            printf("YES.\n");
            Print(icase);
            printf("FINISH\n");
        }
        else
        {
            printf("NO.\n");
            printf("FINISH\n");
        }   
    }

    return 0;
}

void Push(Train* train)
{
    train->top++;
    scanf("%c",&train->order[train->top]);
}

char Pop(Train* train)
{
    char result = ' ';

    result = train->order[train->top];
    train->top--;

    return result;
}

int Judge(Train* train, char order[], int icase)
{
    int i = 0;

    for (; i<icase; i++)
    {
        if (Pop(train) == order[i])
        {
            continue;
        }
        else
        {
            return 0;
        }
    }
   
    if (Empty(train))
    {
        return 1;
    }
    else
    {
        return 0;
    }
}

void Print(int icase)
{
    int i = 0;

    for (; i<icase; i++)
    {
        printf("in\n");
    }

    for (i=0; i<icase; i++)
    {
        printf("out\n");
    }
}

int Empty(Train* train)
{
    if (train->top == -1)
    {
        return 1;
    }
    else
    {
        return 0;
    }
}

-不想让你发现我 凌乱的脚步 ,我努力 跟上你的速度
2010-07-19 09:42
LegendofMine
该用户已被删除
收藏
得分:20 
提示: 作者被禁止或删除 内容自动屏蔽
2010-07-22 06:47
LegendofMine
该用户已被删除
收藏
得分:0 
提示: 作者被禁止或删除 内容自动屏蔽
2010-07-22 07:49
Alen0128
Rank: 4
等 级:业余侠客
帖 子:171
专家分:222
注 册:2009-12-26
收藏
得分:0 
回复 3楼 LegendofMine
不好意思,回晚了
这个123,213怎么意思?

-不想让你发现我 凌乱的脚步 ,我努力 跟上你的速度
2010-07-30 17:23
hzh512
Rank: 9Rank: 9Rank: 9
等 级:蜘蛛侠
威 望:6
帖 子:234
专家分:1333
注 册:2009-6-5
收藏
得分:0 
ACM经典老题目了,就是给出所有可能的出栈序列

编程=用几种语言在某个或几个平台上通过抽象思维运用一系列算法来解决现实中问题的手段
2010-08-09 11:35
快速回复:求教:一道关于栈的问题
数据加载中...
 
   



关于我们 | 广告合作 | 编程中国 | 清除Cookies | TOP | 手机版

编程中国 版权所有,并保留所有权利。
Powered by Discuz, Processed in 0.015854 second(s), 9 queries.
Copyright©2004-2024, BCCN.NET, All Rights Reserved