| 网站首页 | 业界新闻 | 小组 | 威客 | 人才 | 下载频道 | 博客 | 代码贴 | 在线编程 | 编程论坛
欢迎加入我们,一同切磋技术
用户名:   
 
密 码:  
共有 734 人关注过本帖
标题:[求助]一道算法题目
只看楼主 加入收藏
lw8484654
Rank: 1
等 级:新手上路
帖 子:223
专家分:0
注 册:2005-12-1
收藏
 问题点数:0 回复次数:2 
[求助]一道算法题目

Description
Businesses like to have memorable telephone numbers. One way to make a telephone number memorable is to have it spell a memorable word or phrase. For example, you can call the University of Waterloo by dialing the memorable TUT-GLOP. Sometimes only part of the number is used to spell a word. When you get back to your hotel tonight you can order a pizza from Gino's by dialing 310-GINO. Another way to make a telephone number memorable is to group the digits in a memorable way. You could order your pizza from Pizza Hut by calling their ``three tens'' number 3-10-10-10.

The standard form of a telephone number is seven decimal digits with a hyphen between the third and fourth digits (e.g. 888-1200). The keypad of a phone supplies the mapping of letters to numbers, as follows:

A, B, and C map to 2
D, E, and F map to 3
G, H, and I map to 4
J, K, and L map to 5
M, N, and O map to 6
P, R, and S map to 7
T, U, and V map to 8
W, X, and Y map to 9

There is no mapping for Q or Z. Hyphens are not dialed, and can be added and removed as necessary. The standard form of TUT-GLOP is 888-4567, the standard form of 310-GINO is 310-4466, and the standard form of 3-10-10-10 is 310-1010.

Two telephone numbers are equivalent if they have the same standard form. (They dial the same number.)

Your company is compiling a directory of telephone numbers from local businesses. As part of the quality control process you want to check that no two (or more) businesses in the directory have the same telephone number.

Input
The input will consist of one case. The first line of the input specifies the number of telephone numbers in the directory (up to 100,000) as a positive integer alone on the line. The remaining lines list the telephone numbers in the directory, with each number alone on a line. Each telephone number consists of a string composed of decimal digits, uppercase letters (excluding Q and Z) and hyphens. Exactly seven of the characters in the string will be digits or letters.


Output
Generate a line of output for each telephone number that appears more than once in any form. The line should give the telephone number in standard form, followed by a space, followed by the number of times the telephone number appears in the directory. Arrange the output lines by telephone number in ascending lexicographical order. If there are no duplicates in the input print the line:

No duplicates.


Sample Input


12
4873279
ITS-EASY
888-4567
3-10-10-10
888-GLOP
TUT-GLOP
967-11-11
310-GINO
F101010
888-1200
-4-8-7-3-2-7-9-
487-3279


Sample Output


310-1010 2
487-3279 4
888-4567 3
大体是说电话号码为了方便记忆,可以按以下的形式来记录:
A, B, and C map to 2
D, E, and F map to 3
G, H, and I map to 4
J, K, and L map to 5
M, N, and O map to 6
P, R, and S map to 7
T, U, and V map to 8
W, X, and Y map to 9
(Q和Z没有映射)
现在给定一个输入,第一行是电话号码的总数(不超过100,000),接下来就是一行一个号码了,这个号码的形式有很多种(由大写字母(除去Q,Z)和十进制数以及连接符-组成,其中大写字母加十进制数的总个数是7,而连接符号可以任意放置在字母,数字的前后中间)

要求输出:
如果输入里没有重复的电话号码就打印 No duplicates
如果有那就以标准形式XXX-XXXX(X代表一个十进制数)把电话号码记录下来,并在其后记录这个号码出现的次数。并且所有号码要以升序排列。
有谁帮我看下这个程序错在哪里了呢?
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#define N 100000

struct Element
{
long mark[N];
long num[N];
}e;

int sort(const void *a, const void *b)
{
return *(int*)a-*(int*)b;
}

int main()
{
long n,i,j,k=0;
long count;
char array[N];
scanf("%ld",&n);
for(i=0;i<n;i++)
{
scanf("%s",array);
for(j=0;j<strlen(array);j++)
{
if(array[j]!='-')
{
switch(array[j])
{
case 'A':case 'B':case 'C':e.mark[i]=e.mark[i]*10+'2'-'0';break;
case 'D':case 'E':case 'F':e.mark[i]=e.mark[i]*10+'3'-'0';break;
case 'G':case 'H':case 'I':e.mark[i]=e.mark[i]*10+'4'-'0';break;
case 'J':case 'K':case 'L':e.mark[i]=e.mark[i]*10+'5'-'0';break;
case 'M':case 'N':case 'O':e.mark[i]=e.mark[i]*10+'6'-'0';break;
case 'P':case 'R':case 'S':e.mark[i]=e.mark[i]*10+'7'-'0';break;
case 'T':case 'U':case 'V':e.mark[i]=e.mark[i]*10+'8'-'0';break;
case 'W':case 'X':case 'Y':e.mark[i]=e.mark[i]*10+'9'-'0';break;
default:e.mark[i]=e.mark[i]*10+array[j]-'0';
}
}
}
}
//for(i=0;i<n;i++)printf("%d\n",e.mark[i]);system("PAUSE");
qsort((void*)e.mark,n,sizeof(long),sort);

for(i=0;i<n;i++)
{
count=1;
for(j=i+1;j<n;j++)
{
if(e.mark[i]==e.mark[j]){count++;i++;}
}

if(count>1)
{
k=1;
printf("%d",e.mark[i]/10000);
printf("-");
printf("%d",e.mark[i]%10000);
printf(" %d\n",count);
}
}
if(!k)printf("No duplicates. \n");
return 0;
}

搜索更多相关主题的帖子: 算法 memorable telephone number 
2007-04-20 13:12
lq317883361
Rank: 1
等 级:新手上路
帖 子:23
专家分:0
注 册:2007-4-20
收藏
得分:0 
英文太多,我看不懂.
2007-04-22 09:10
soft_wind
Rank: 3Rank: 3
等 级:新手上路
威 望:8
帖 子:1430
专家分:0
注 册:2006-4-5
收藏
得分:0 

看了题,又看了下你的程序,发现了2处错误:
1."in ascending lexicographical order"的意思应该是按字典序,并不是按大小序.也就是说比较接口函数应该是strcmp()函数,这样你的程序基本上得重新编写。
2. for(i=0;i<n;i++)
{
count=1;
for(j=i+1;j<n;j++)
{
if(e.mark[i]==e.mark[j]){count++;i++;}
}

if(count>1)
{
k=1;
printf("%d",e.mark[i]/10000);
printf("-");
printf("%d",e.mark[i]%10000);
printf(" %d\n",count);
}
}
这段程序里有2个小错误。一个是红色的i++不需要;另外一个是,当你确定e.mark[i]为重复串的时候,必然在i-n之间至少有一个和e.mark[i]是相同的,当e.mark[i]的count>=3时,后面的重复mark仍会被继续输出。
另外,你开的e.num是干吗?


对不礼貌的女生收钱......
2007-04-22 21:19
快速回复:[求助]一道算法题目
数据加载中...
 
   



关于我们 | 广告合作 | 编程中国 | 清除Cookies | TOP | 手机版

编程中国 版权所有,并保留所有权利。
Powered by Discuz, Processed in 0.013960 second(s), 8 queries.
Copyright©2004-2024, BCCN.NET, All Rights Reserved