| 网站首页 | 业界新闻 | 小组 | 威客 | 人才 | 下载频道 | 博客 | 代码贴 | 在线编程 | 编程论坛
欢迎加入我们,一同切磋技术
用户名:   
 
密 码:  
共有 564 人关注过本帖
标题:杭电1008 升降机问题
只看楼主 加入收藏
xwxc
Rank: 1
等 级:新手上路
帖 子:10
专家分:2
注 册:2012-11-17
结帖率:100%
收藏
已结贴  问题点数:20 回复次数:3 
杭电1008 升降机问题
我哪错了、老是AC不了。谢谢各位大仙、

Problem Description
The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.
 

Input
There are multiple test cases. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100. A test case with N = 0 denotes the end of input. This test case is not to be processed.
 

Output
Print the total time on a single line for each test case.
 

Sample Input
1 2
3 2 3 1
0
 

Sample Output
17
41
 

程序代码:
#include <stdio.h>
int main()
{
    char a[1000];
    int i,c,n;
    scanf("%d",&n);
    while(n!=0)
    {
    n++;
    a[0]='0';

    //输入
    for(i=1;i<n;i++)
    {
    scanf("%c",&a[i]);
    if(a[i]==' ') 
    {
        i--;
    }
    if(a[i]=='\n')
    {
        a[i]='\0';
        break;
    }
    }
    //计算
    
        c=0;
        for(i=1;i<n;i++)
        {
            if(a[i]-a[i-1]>0)
            {
                c+=(a[i]-a[i-1])*6+5;

            }
            else if(a[i]-a[i-1]<0)
            {
                c+=(a[i-1]-a[i])*4+5;

            }
            else
            {
                c+=5;
            }
        }
        
    printf("%d\n",c);
    scanf("%d",&n);
    }

    

    return 0;
}
搜索更多相关主题的帖子: 升降机 1008 specified positive building 
2013-04-06 21:08
Susake
Rank: 15Rank: 15Rank: 15Rank: 15Rank: 15
来 自:女儿国的隔壁
等 级:贵宾
威 望:23
帖 子:2288
专家分:6481
注 册:2012-12-14
收藏
得分:16 
程序代码:
#include <stdio.h>

int main() {
    int n, a[110], sum, i;
    while(scanf("%d", &n) && n != 0) {
        sum = 0;
        for(i = 1; i <= n; i++) scanf("%d", &a[i]);
        for(i = 1, a[0] = 0; i <= n; i++) {
            if(a[i] > a[i - 1]) sum += (a[i] - a[i - 1]) * 6 + 5;
            else sum += (a[i - 1] - a[i]) * 4 + 5;
        }
        printf("%d\n", sum);
    }
    return 0;
}

仰望星空...........不忘初心!
2013-04-06 21:10
mskeheng
Rank: 3Rank: 3
等 级:论坛游侠
帖 子:48
专家分:179
注 册:2013-3-13
收藏
得分:4 
楼主用字符窜类型,表面上节省空间,但是在输入上参生很大的困难。所以楼上版主的,用整型有利于与数据输入,不过感觉上面版主的程序有一点小问题,就是到大目标层的时候,停的时间应该是不算的,但楼上版主算了。看后一点点想法,小白水准,若说错,望见谅
2013-04-06 22:01
Susake
Rank: 15Rank: 15Rank: 15Rank: 15Rank: 15
来 自:女儿国的隔壁
等 级:贵宾
威 望:23
帖 子:2288
专家分:6481
注 册:2012-12-14
收藏
得分:0 
以下是引用mskeheng在2013-4-6 22:01:11的发言:

楼主用字符窜类型,表面上节省空间,但是在输入上参生很大的困难。所以楼上版主的,用整型有利于与数据输入,不过感觉上面版主的程序有一点小问题,就是到大目标层的时候,停的时间应该是不算的,但楼上版主算了。看后一点点想法,小白水准,若说错,望见谅
呵呵,我想你想多了,对于int型来说,应该已经算大了....而且题目是输入的层次的时间是暂停的...还有,我想你没仔细看题吧...最高不超过100层..

[ 本帖最后由 Susake 于 2013-4-6 22:13 编辑 ]

仰望星空...........不忘初心!
2013-04-06 22:09
快速回复:杭电1008 升降机问题
数据加载中...
 
   



关于我们 | 广告合作 | 编程中国 | 清除Cookies | TOP | 手机版

编程中国 版权所有,并保留所有权利。
Powered by Discuz, Processed in 0.015625 second(s), 8 queries.
Copyright©2004-2024, BCCN.NET, All Rights Reserved