| 网站首页 | 业界新闻 | 小组 | 威客 | 人才 | 下载频道 | 博客 | 代码贴 | 在线编程 | 编程论坛
欢迎加入我们,一同切磋技术
用户名:   
 
密 码:  
共有 461 人关注过本帖
标题:我只是想知道在PC上运行正确的程序为啥在杭电上通不过
只看楼主 加入收藏
hedaacm
Rank: 6Rank: 6
来 自:河北保定
等 级:侠之大者
威 望:2
帖 子:400
专家分:418
注 册:2012-1-26
结帖率:79.41%
收藏
 问题点数:0 回复次数:2 
我只是想知道在PC上运行正确的程序为啥在杭电上通不过
程序代码:
求高手指教!!!

杭电1008
Elevator
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 22864    Accepted Submission(s): 12239


Problem Description
The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.


 

Input
There are multiple test cases. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100. A test case with N = 0 denotes the end of input. This test case is not to be processed.


 

Output
Print the total time on a single line for each test case. 


 

Sample Input
1 2
3 2 3 1
0

 

Sample Output
17
41
题目大概意思:上一阶楼梯花6秒,下一阶楼梯花4秒,每上下一次电梯要停留4秒。最后求出上下楼梯花费的总时间。


#include<iostream>
using namespace std;
int main()
{
   int a[100]={0},n;
  
   while(cin>>n&&n)
   {   
        int up=0,down=0,sum=0;    
             
       for(int i=0;i<n;i++)
         cin>>a[i];
        
      
       for(int i=0;i<n-1;i++)
         {
             if(a[i+1]>a[i])
                up+=(a[i+1]-a[i]);
               
             else if(a[i+1]<a[i])
                down+=(a[i]-a[i+1]);
               
                    
         }          
               
                up=up+a[0];
            sum=up*6+down*4+5*n;
           
            cout<<sum<<endl;   
           
               
   }
   
    return 0;
}



搜索更多相关主题的帖子: only one positive building request 
2012-05-01 13:11
hedaacm
Rank: 6Rank: 6
来 自:河北保定
等 级:侠之大者
威 望:2
帖 子:400
专家分:418
注 册:2012-1-26
收藏
得分:0 
以上是AC代码
2012-05-01 13:13
wangjieest
Rank: 2
等 级:论坛游民
帖 子:5
专家分:20
注 册:2011-10-20
收藏
得分:0 
这一题原来是很简单 ,做出来测试了几个数据还是感觉是对的,可是提交上去怎么都是错的。后来百度了下才知道我也和大家一样,没有考虑电梯停在同一层的情况,如2 0 0  这样的情况就应该是10.唉唉,以后还是要考虑全面啊!!!这个记住了!
2012-05-08 17:33
快速回复:我只是想知道在PC上运行正确的程序为啥在杭电上通不过
数据加载中...
 
   



关于我们 | 广告合作 | 编程中国 | 清除Cookies | TOP | 手机版

编程中国 版权所有,并保留所有权利。
Powered by Discuz, Processed in 0.015149 second(s), 8 queries.
Copyright©2004-2024, BCCN.NET, All Rights Reserved