| 网站首页 | 业界新闻 | 小组 | 威客 | 人才 | 下载频道 | 博客 | 代码贴 | 在线编程 | 编程论坛
欢迎加入我们,一同切磋技术
用户名:   
 
密 码:  
共有 1240 人关注过本帖
标题:stl的一道题
只看楼主 加入收藏
lemonandtree
Rank: 2
等 级:论坛游民
帖 子:74
专家分:10
注 册:2017-10-5
结帖率:88.89%
收藏
已结贴  问题点数:20 回复次数:4 
stl的一道题
Given is an ordered deck of n cards numbered 1 to n with card 1 at the top and card n at the bottom. The following operation is performed as long as there are at least two cards in the deck:
Throw away the top card and move the card that is now on the top of the deck to the bottom of the deck.
Your task is to find the sequence of discarded cards and the last, remaining card.
Input
Each line of input (except the last) contains a number n ≤ 50. The last line contains ‘0’ and this line should not be processed.
Output
For each number from the input produce two lines of output. The first line presents the sequence of discarded cards, the second line reports the last remaining card. No line will have leading or trailing spaces. See the sample for the expected format.
Sample Input
7 19 10 6 0
Sample Output
Discarded cards: 1, 3, 5, 7, 4, 2
Remaining card: 6
Discarded cards: 1, 3, 5, 7, 9, 11, 13, 15, 17, 19, 4, 8, 12, 16, 2, 10, 18, 14
Remaining card: 6
Discarded cards: 1, 3, 5, 7, 9, 2, 6, 10, 8
Remaining card: 4
Discarded cards: 1, 3, 5, 2, 6
Remaining card: 4
我写了两份代码
第一份一直过不了
第二份一下就accept了
希望有大神帮我一下
第一份:
程序代码:
#include<iostream>
#include<vector>
using namespace std;
int y(int n)
{
    int i=1;
    vector<int>v,x;
    vector<int>::iterator it;
    for(i=0;i<n;i++)
        v.push_back(i+1);
    while(v.size()!=1)
    {
            x.push_back(v[0]);
          v.erase(v.begin());
          v.push_back(v[0]);
          v.erase(v.begin());
          }
          printf("Discarded cards: ");
          for(it=x.begin();it!=x.end();it++)
            {
                if(it!=x.end()-1)
            {
                printf("%d",*it);printf(", ");
            }
            else cout<<*it<<endl;    }
           printf("Remaining card: ");
            it=v.begin();
            cout<<*it<<endl;
           return 0;
           }
int main()
{    int i,t=0;
int n=1;
while(scanf("%d",&n)!=0)
    {
         if(n==0)
     break;
         y(n);   }
        return 0;}


第二份:
#include<iostream>
#include<queue>
#include<vector>
#include<algorithm>
using namespace std;
int main()
{
    int n;
    while(cin>>n&&n!=0)
    {
        queue<int> q;
        vector<int> v;
        for(int i=1;i<=n;i++)
        {
            q.push(i);
        }
        while(q.size()>=2)
        {
            v.push_back(q.front());
            q.pop();
            int tail=q.front();
            q.pop();
            q.push(tail);
        }
        cout<<"Discarded cards:";
        for(int i=0;i<v.size();i++)
        {
            if(i!=0)
            cout<<",";
            cout<<" ";
            cout<<v[i];
        }
        cout<<endl;
        cout<<"Remaining card: ";
        cout<<q.front()<<endl;
    }
    return 0;
}
第一份的运行结果
图片附件: 游客没有浏览图片的权限,请 登录注册
图片附件: 游客没有浏览图片的权限,请 登录注册

第二份:
图片附件: 游客没有浏览图片的权限,请 登录注册
图片附件: 游客没有浏览图片的权限,请 登录注册


搜索更多相关主题的帖子: the line include int cout 
2018-04-29 11:05
rjsp
Rank: 20Rank: 20Rank: 20Rank: 20Rank: 20
等 级:版主
威 望:528
帖 子:9007
专家分:53942
注 册:2011-1-18
收藏
得分:20 
int main()
{    int i,t=0;
int n=1;
while(scanf("%d",&n)!=0)
    {
         if(n==0)
     break;
         y(n);   }
        return 0;}
你写的是什么天书?
当初用笔的时候,某些人字写得潦草得让别人看不懂;
现在用键盘了,没法写出潦草的字了,那就格式乱排。

while(scanf("%d",&n)!=0) 这完全不符合题目要求(“The last line contains 0”)吧,题目要求对应的代码应该是 while( scanf("%d",&n)==1 && n!=0 )
2018-05-02 09:24
lemonandtree
Rank: 2
等 级:论坛游民
帖 子:74
专家分:10
注 册:2017-10-5
收藏
得分:0 
嗯,但我改了之后还是格式错误
图片附件: 游客没有浏览图片的权限,请 登录注册
图片附件: 游客没有浏览图片的权限,请 登录注册
2018-05-02 22:25
lemonandtree
Rank: 2
等 级:论坛游民
帖 子:74
专家分:10
注 册:2017-10-5
收藏
得分:0 
图片附件: 游客没有浏览图片的权限,请 登录注册
2018-05-02 22:27
lemonandtree
Rank: 2
等 级:论坛游民
帖 子:74
专家分:10
注 册:2017-10-5
收藏
得分:0 
图片附件: 游客没有浏览图片的权限,请 登录注册
2018-05-02 22:28
快速回复:stl的一道题
数据加载中...
 
   



关于我们 | 广告合作 | 编程中国 | 清除Cookies | TOP | 手机版

编程中国 版权所有,并保留所有权利。
Powered by Discuz, Processed in 0.016621 second(s), 9 queries.
Copyright©2004-2024, BCCN.NET, All Rights Reserved